Quantcast
Download
(310 Kb)
Download
Updated: 09-07-19 11:50 PM
Pictures
File Info
Compatibility:
Rise of Azshara (8.2.0)
Updated:09-07-19 11:50 PM
Created:08-07-09 11:52 PM
Downloads:25,846
Favorites:117
MD5:
Categories:Raid Mods, Healers, Unit Mods
8.2.0

Aptechka  Updated this week!  Popular! (More than 5000 hits)

Version: 8.2.17
by: d87 [More]

Aptechka is a raid frames addon.

THIS IS LIVE VERSION

Notable features:
- Autoscaling based on role/raid size.
- Debuff icons with a blacklist
- Preconfigured for all healing classes with a variety of indicator types
- Incoming casts display
- Spell Locks as debuffs
- Debuff ordering
- Feedback indicators for smart aoe heals

Console command: /apt
github







In case anyone was still using userconfigs, here's the
new example config with PostFrameUpdate hook

### 8.2.16:

- fixed possible frame glitches on login
- fixed Growth not setting correctly on login

### 8.2.15:

- fixed issue with arcane mages mana doing weird things

### 8.2.14:

- Priest config update

### 8.2.13:

- A lot of internal changes to frame contruction
- Removed inverted colors setting
- Instead you now can switch between reverse filling of the health bar
- Color multiplier settings for fg/bg/name
- Name outline setting
- Bugfixes

### 8.2.12:

- Targeted Casts feature
- bugfixes

### 8.2.11:

- Removed old skin support
- Added Aptechka.PostFrameUpdate for skinning

### 8.2.9:

- fixed error caused by added from GUI spells

### 8.2.8:

- increased aura handling performance

### 8.2.7:

- fixed LoS warning
- fixed missing health formatting on low level characters
- added heal absorb bar
- not showing missing spell indicators if they aren't learned yet

### 8.2.6:

- Workaround for 8.1 SGH missing units bug, but this time for raids

### 8.2.5:

- Stagger indicator
- Other active mitigation icons
- Blessing of Sacrifice icon
- Font is now adjustable
- Debuff size is now adjustable
- Hopefully fixed summon text getting stuck

### 8.2.4:

- Incoming Summon indicator
- disabled LibCLH

### 8.2.3:

- fixed role icons

### 8.2.2:

- minor bugfixes
- added blacklist info to GUI
- added Dampening to blacklist

### 8.2.1:

- fixed the issue with UnitButtons not appearing until out of combat
- blacklisted nazjatar debuffs

### 8.2.0:

- Better hiding blizzard raid frames
- Added spell ranks support
- Classic compatibility
- Added Standstill and Vitality Conduit

### 8.1.5:

- proper fix for 8.1 "Unknown" units bug

### 8.1.2:

- Shift-RightClick now toggles menu
- Option to disable tooltips completely
Archived Files (56)
File Name
Version
Size
Author
Date
8.2.16
310kB
d87
09-04-19 02:35 AM
8.2.15
310kB
d87
08-26-19 07:55 AM
8.2.14
310kB
d87
08-25-19 04:26 AM
8.2.12
310kB
d87
08-18-19 09:19 PM
8.2.11
305kB
d87
08-10-19 10:55 AM
8.2.10
305kB
d87
08-08-19 01:14 PM
8.2.9
305kB
d87
08-08-19 09:37 AM
8.2.8
305kB
d87
08-06-19 01:40 PM
8.2.7
305kB
d87
07-29-19 05:20 AM
8.2.6
302kB
d87
07-22-19 02:31 AM
8.2.5
302kB
d87
07-19-19 10:08 AM
8.2.4
304kB
d87
07-11-19 12:25 PM
8.2.3
304kB
d87
07-04-19 01:22 AM
8.2.2
304kB
d87
07-02-19 06:58 AM
8.2.1
307kB
d87
06-26-19 11:33 PM
8.2.0
307kB
d87
06-25-19 06:53 AM
8.1.5
304kB
d87
04-13-19 04:14 AM
8.1.3
304kB
d87
02-13-19 05:19 AM
8.1.2
304kB
d87
12-31-18 09:56 PM
8.1.1
304kB
d87
12-15-18 10:25 AM
8.1.0
303kB
d87
12-11-18 01:55 AM
8.0.12
303kB
d87
09-27-18 01:29 PM
8.0.11
303kB
d87
09-27-18 12:39 PM
8.0.10
303kB
d87
09-20-18 05:51 AM
8.0.9
301kB
d87
09-15-18 02:08 PM
8.0.8
301kB
d87
09-14-18 09:19 AM
8.0.7
301kB
d87
09-13-18 10:09 PM
8.0.6
281kB
d87
09-03-18 10:38 AM
8.0.5
280kB
d87
08-19-18 12:58 AM
8.0.4
280kB
d87
07-30-18 05:51 AM
8.0.3
278kB
d87
07-22-18 10:02 AM
8.0.2
279kB
d87
07-17-18 10:18 PM
8.0.1
279kB
d87
07-17-18 07:28 AM
7.3.9
270kB
d87
04-09-18 04:44 PM
7.3.8
270kB
d87
10-29-17 05:14 AM
7.3.4
176kB
d87
10-26-17 01:33 PM
7.3.3
182kB
d87
10-05-17 03:40 PM
7.3.2
182kB
d87
09-26-17 06:07 AM
7.3.1
182kB
d87
08-31-17 10:59 AM
2.5.6a
181kB
d87
06-09-17 07:46 PM
2.5.5a
181kB
d87
10-25-16 04:51 AM
2.5.4
186kB
d87
10-05-16 12:13 PM
2.5.3a
212kB
d87
08-30-16 08:55 PM
2.5.2
206kB
d87
08-07-16 11:20 AM
2.5.1
206kB
d87
08-01-16 08:27 AM
2.4.2
199kB
d87
11-16-14 12:49 PM
2.4.1
199kB
d87
11-05-14 11:43 AM
2.4.0
173kB
d87
10-14-14 11:20 AM
2.3.1
163kB
d87
05-22-13 07:39 PM
2.3.0
163kB
d87
04-07-13 01:00 AM
2.2.3
159kB
d87
11-23-12 10:03 AM
2.2.1
158kB
d87
10-14-12 06:06 AM
2.2.0
158kB
d87
08-28-12 08:09 AM
2.1.10 [50000]
151kB
d87
08-19-12 10:57 AM
2.1.9 [50000]
151kB
d87
07-03-12 05:14 AM
2.1.8 [50000]
151kB
d87
07-01-12 07:23 AM


Post A Reply Comment Options
Unread 02-13-19, 05:28 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
alright, sorry people about this "Unknown" bug. I should've known not to expect things to get fixed at the very least until next major patch. It hopefully works now
Last edited by d87 : 02-13-19 at 09:05 AM.
Report comment to moderator  
Reply With Quote
Unread 02-01-19, 11:59 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
well i haven't changed anything. There's currently a pretty major bug going on all over ( https://twitter.com/WeakAuras/status...75132263022592 ) Maybe that's causing bugs with vehicles, tho I can't confirm.
Last edited by d87 : 02-01-19 at 12:02 PM.
Report comment to moderator  
Reply With Quote
Unread 02-01-19, 09:50 AM  
strickland
An Aku'mai Servant

Forum posts: 36
File comments: 192
Uploads: 0
Hey, just a question, I used to be able to know if someone inside of my raid is inside a vehicle, I remember his/her grid turns light green or something or maybe I think his grid will have a Greened Border? I can't remember exactly but one of the two.

then I will also know which vehicle he accessed by clicking on his grid, but now apparently I can't tell if somebody went into a vehicle or not, is that change from blizzard or from you? or is it something in the option that I can turn on?
Report comment to moderator  
Reply With Quote
Unread 12-31-18, 09:59 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
added Shift-RMB for menu

i don't really understand what exactly you want from tooltips. They are already not shown in combat, but anyway, now you can disable them always
Report comment to moderator  
Reply With Quote
Unread 12-31-18, 04:38 PM  
jessica
A Cyclonian

Forum posts: 41
File comments: 136
Uploads: 0
Hi d87, I got two questions.

1) Is there anyway to disable tooltip from showing only from injection/aptechka? for example, I like tooltip to appear on mousehover, even in combat I have that enabled, however on my aptechka grids I want it so that the tooltip doesn't show only in that place, is there anyway to do it by adding a simple code in my userconfig?


2) Is there an easy way to make the right-click menu work when clicking the aptechka grids in the same manner when you you use right-click while having a target for example, that way you can remove, or promote, or change leader, or assist tank, or assign a mark, or even set focus from the aptechka frame after using right click on anybody in the raid, then chose whatever you want to do, I think it's a good idea.


Thanks
Report comment to moderator  
Reply With Quote
Unread 12-29-18, 08:25 AM  
jessica
A Cyclonian

Forum posts: 41
File comments: 136
Uploads: 0
Originally Posted by d87
Since 8.1 wow update? That's probably another client bug then, there was something similar (but different) in 8.0 and I ended up making several periodic updates of everything for 30 seconds after joining a group. If even that is not helping, then idk... probably something just gets stuck. I'll have to see for myself later
Maybe its a conflict with another addon, I will disable one by one everyday cause it only happens when joining groups, and not all the time that it happens, however I'll try to see which addon is conflicting and causing this.
Report comment to moderator  
Reply With Quote
Unread 12-28-18, 11:15 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
Since 8.1 wow update? That's probably another client bug then, there was something similar (but different) in 8.0 and I ended up making several periodic updates of everything for 30 seconds after joining a group. If even that is not helping, then idk... probably something just gets stuck. I'll have to see for myself later
Report comment to moderator  
Reply With Quote
Unread 12-27-18, 09:48 AM  
jessica
A Cyclonian

Forum posts: 41
File comments: 136
Uploads: 0
Something weird been happening lately since update, whenever I join instance or scenario or whatever group, sometimes and not all the times, but it happens often though, that all names become white and name is "unknown" I have to /reloadui to fix it.
Report comment to moderator  
Reply With Quote
Unread 09-21-18, 06:26 PM  
Xully
An Aku'mai Servant

Forum posts: 33
File comments: 174
Uploads: 0
Sorry for late response, but yes I do have warmode ON / enabled.

Plus yes, my load time takes forever, I don't know why, but it does take quite a long time in the loading screen, specially when I first login.
Report comment to moderator  
Reply With Quote
Unread 09-20-18, 05:52 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
in 8.0.10 offline status should fix itself withing 10s after entering dungeon, but yeah it was a game bug
Last edited by d87 : 09-20-18 at 05:53 AM.
Report comment to moderator  
Reply With Quote
Unread 09-19-18, 09:35 PM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
Originally Posted by Xully
I havent tried dungeons yet, as I play casually, but I'm joining expeditions (The new scenarios) and each time I join, I have to reload because the other two party members look offline to me.
I've encountered that a few times in LFD, but it was very rare, in less than 10% of groups. And considering it worked perfectly for years and i haven't changed anything, i was wondering if other addons have the same issue, because it is could be something on blizzard's side
anyway, i'll try to do what i can
if you get it often, do you have warmode on or off?
Do you have long loading times?
Last edited by d87 : 09-19-18 at 09:45 PM.
Report comment to moderator  
Reply With Quote
Unread 09-19-18, 04:37 PM  
Xully
An Aku'mai Servant

Forum posts: 33
File comments: 174
Uploads: 0
I havent tried dungeons yet, as I play casually, but I'm joining expeditions (The new scenarios) and each time I join, I have to reload because the other two party members look offline to me.
Report comment to moderator  
Reply With Quote
Unread 09-14-18, 09:25 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
Originally Posted by strickland
Originally Posted by d87
yes

Post your config
or wait, if you set orientation back to horizontal and reload, is the sqaure gone then? (the square is from absorb shield i assume)
sent you message with the whole code, in a link. Plus my incheal bar prediction doesn't work again, for some reason, I didn't touch the code that I changed inside my userconfg about this matter too.
ok, it works fine with the fix i just uploaded to wowi. incoming heal works too, it's just barely visible on the black background.
there's nothing more i can do for incoming heals, those are values from wow api and they're garbage that is useless 90% of time, because it doesn't account for crits, procs, or whatever else, hots barely count too. Predictions end up being very wrong
Last edited by d87 : 09-14-18 at 09:29 AM.
Report comment to moderator  
Reply With Quote
Unread 09-14-18, 09:10 AM  
strickland
An Aku'mai Servant

Forum posts: 36
File comments: 192
Uploads: 0
Originally Posted by d87
yes

Post your config
or wait, if you set orientation back to horizontal and reload, is the sqaure gone then? (the square is from absorb shield i assume)
sent you message with the whole code, in a link. Plus my incheal bar prediction doesn't work again, for some reason, I didn't touch the code that I changed inside my userconfg about this matter too.
Report comment to moderator  
Reply With Quote
Unread 09-14-18, 08:39 AM  
d87
A Flamescale Wyrmkin
 
d87's Avatar
AddOn Author - Click to view AddOns

Forum posts: 136
File comments: 583
Uploads: 38
how can I keep using my userconfig settings plus trying out your GUI skins, should I just comment out the custom skin line?
yes

EDIT: just tried with my config, it works fine except my own grid frame is covered by a white square.
Post your config
or wait, if you set orientation back to horizontal and reload, is the sqaure gone then? (the square is from absorb shield i assume)
Last edited by d87 : 09-14-18 at 09:02 AM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump:

Support AddOn Development!

You have just downloaded by the author . If you like this AddOn why not consider supporting the author? This author has set up a donation account. Donations ensure that authors can continue to develop useful tools for everyone.