Quantcast
Download
(732 b)
Download
Updated: 09-02-19 02:38 AM
Pictures
File Info
Compatibility:
WoW Classic (1.13.2)
Updated:09-02-19 02:38 AM
Created:08-10-19 12:06 PM
Downloads:6,246
Favorites:12
MD5:
Categories:Shaman, Classic - General

aBlueShaman  Popular! (More than 5000 hits)

Version: 1.1
by: cocovanana [More]

Intro

Just a quick add-on I wrote to make shamans' color blue in classic too! Currently the way I found to make it load before other add-ons was to just name it starting with an 'a'. I'm not an add-on expert, so there may be a better way I'm missing, so I'm open for criticism!

Heads up to Bouyou for his help with the hex color problem!

Changelog
  • 1.0: Initial upload
  • 1.1: Fixed hex color which was conflicting with WeakAuras2.

Optional Files (0)


Archived Files (1)
File Name
Version
Size
Author
Date
1.0
661B
cocovanana
08-10-19 12:06 PM


Post A Reply Comment Options
Unread 09-13-19, 03:22 AM  
cocovanana
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 23
Uploads: 5
Re: Why not post this addon to curseForge?

Originally Posted by wolfcon
Hope for that.
Hey, thanks for the interest! I do have the intention to put all my addons there too, but their addon upload form is broken
Last edited by cocovanana : 09-13-19 at 08:00 AM.
Report comment to moderator  
Reply With Quote
Unread 09-13-19, 01:31 AM  
wolfcon
A Kobold Labourer

Forum posts: 0
File comments: 3
Uploads: 0
Why not post this addon to curseForge?

Hope for that.
Report comment to moderator  
Reply With Quote
Unread 08-29-19, 10:10 AM  
cocovanana
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 23
Uploads: 5
Originally Posted by Bouyou
Hello, you need to convert the color in hex format
Hey! Thanks a lot! I'll update the code as soon as I'm home!
Report comment to moderator  
Reply With Quote
Unread 08-29-19, 09:01 AM  
Bouyou
A Kobold Labourer

Forum posts: 0
File comments: 2
Uploads: 0
Hello, you need to convert the color in hex format

Lua Code:
  1. RAID_CLASS_COLORS["SHAMAN"] = CreateColor(0, 0.44, 0.87, 1)
  2. RAID_CLASS_COLORS["SHAMAN"].colorStr = RAID_CLASS_COLORS["SHAMAN"]:GenerateHexColor()
Last edited by Bouyou : 08-29-19 at 09:06 AM.
Report comment to moderator  
Reply With Quote
Unread 08-22-19, 12:58 PM  
cocovanana
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 23
Uploads: 5
Originally Posted by b3n9ti
.......
Thanks for the logs! I see there's definetely a problem when WA tries to set some text color. Could you post an export of your auras so I can pinpoint which one is failing an fiddle with it to understand the problem once game launches?

EDIT: Please update to the latest weak auras before re-testing!

EDIT2: I've tried with a couple of shaman weak auras I found on wago, but didn't get any error so far. I also got some class colored health bars to show without problem.
Last edited by cocovanana : 08-28-19 at 09:13 AM.
Report comment to moderator  
Reply With Quote
Unread 08-11-19, 10:56 AM  
b3n9ti
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 70
Uploads: 2
Originally Posted by cocovanana
...
spoke too soon. tried it with only aBlueShaman and the newest WeakAuras activated.

Message: Interface\SharedXML\Util.lua:598: bad argument #1 to 'format' (string expected, got nil)
Time: Sun Aug 11 18:55:47 2019
Count: 1
Stack: Interface\SharedXML\Util.lua:598: bad argument #1 to 'format' (string expected, got nil)
[C]: in function `format'
Interface\SharedXML\Util.lua:598: in function `WrapTextInColorCode'
Interface\AddOns\WeakAuras\Types.lua:197: in main chunk

Locals: (*temporary) = "|c%s%s"
(*temporary) = nil
(*temporary) = "Shaman"
(*temporary) = "string expected, got nil"

---

Message: Interface\AddOns\WeakAuras\Transmission.lua:221: bad argument #1 to 'pairs' (table expected, got nil)
Time: Sun Aug 11 18:55:47 2019
Count: 1
Stack: Interface\AddOns\WeakAuras\Transmission.lua:221: bad argument #1 to 'pairs' (table expected, got nil)
[C]: in function `pairs'
Interface\AddOns\WeakAuras\Transmission.lua:221: in main chunk

Locals: (*temporary) = nil
(*temporary) = "table expected, got nil"
= <function> defined =[C]:-1

---

Message: Interface\AddOns\WeakAuras\WeakAuras.lua:331: bad argument #1 to 'pairs' (table expected, got nil)
[C]: in function `pairs'
Interface\AddOns\WeakAuras\WeakAuras.lua:331: in function `validate'
Interface\AddOns\WeakAuras\WeakAuras.lua:3852: in function `PreAdd'
Interface\AddOns\WeakAuras\WeakAuras.lua:3965: in function `Add'
Interface\AddOns\WeakAuras\WeakAuras.lua:3525: in function <Interface\AddOns\WeakAuras\WeakAuras.lua:3504>
Interface\AddOns\WeakAuras\WeakAuras.lua:3517: in function `load'
Interface\AddOns\WeakAuras\WeakAuras.lua:3532: in function `AddMany'
Interface\AddOns\WeakAuras\WeakAuras.lua:1517: in function <Interface\AddOns\WeakAuras\WeakAuras.lua:1505>

Time: Sun Aug 11 18:55:47 2019
Count: 1
Stack: Interface\AddOns\WeakAuras\WeakAuras.lua:331: bad argument #1 to 'pairs' (table expected, got nil)
[C]: in function `pairs'
Interface\AddOns\WeakAuras\WeakAuras.lua:331: in function `validate'
Interface\AddOns\WeakAuras\WeakAuras.lua:3852: in function `PreAdd'
Interface\AddOns\WeakAuras\WeakAuras.lua:3965: in function `Add'
Interface\AddOns\WeakAuras\WeakAuras.lua:3525: in function <Interface\AddOns\WeakAuras\WeakAuras.lua:3504>
Interface\AddOns\WeakAuras\WeakAuras.lua:3517: in function `load'
Interface\AddOns\WeakAuras\WeakAuras.lua:3532: in function `AddMany'
Interface\AddOns\WeakAuras\WeakAuras.lua:1517: in function <Interface\AddOns\WeakAuras\WeakAuras.lua:1505>


Locals: <none>
Report comment to moderator  
Reply With Quote
Unread 08-11-19, 01:49 AM  
b3n9ti
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 70
Uploads: 2
Originally Posted by cocovanana
Originally Posted by b3n9ti
it breaks WeakAuras2, somehow. and AtlasLoot
Thanks for the feedback! I just downloaded the latest classic version for both WA2 and AtlasLoot and they're working fine for me*. If you have a Lua error message that you can share, that would help pinpoint what's happening!


*Weakauras keeps spitting errors about absorbs and incoming heals (which don't exist in classic, so the WA2 team actually needs to fix this). This happens even when all other Addons are disabled. Other than that, it does work for the couple of test auras I've set up.
seems after updating to a newer WeakAuras it does work now! thanks anyhow
Report comment to moderator  
Reply With Quote
Unread 08-10-19, 06:16 PM  
cocovanana
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 23
Uploads: 5
Originally Posted by b3n9ti
it breaks WeakAuras2, somehow. and AtlasLoot
Thanks for the feedback! I just downloaded the latest classic version for both WA2 and AtlasLoot and they're working fine for me*. If you have a Lua error message that you can share, that would help pinpoint what's happening!


*Weakauras keeps spitting errors about absorbs and incoming heals (which don't exist in classic, so the WA2 team actually needs to fix this). This happens even when all other Addons are disabled. Other than that, it does work for the couple of test auras I've set up.
Last edited by cocovanana : 08-10-19 at 06:27 PM.
Report comment to moderator  
Reply With Quote
Unread 08-10-19, 02:36 PM  
b3n9ti
A Kobold Labourer
AddOn Author - Click to view AddOns

Forum posts: 0
File comments: 70
Uploads: 2
it breaks WeakAuras2, somehow. and AtlasLoot
Last edited by b3n9ti : 08-10-19 at 02:37 PM.
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: