Quantcast
Download
(2 MB)
Download
Updated: 10-20-20 04:28 AM
Pictures
File Info
Compatibility:
Shadowlands pre-patch (9.0.1)
Updated:10-20-20 04:28 AM
Created:11-03-14 10:14 AM
Downloads:19,203
Favorites:66
MD5:
Categories:Minimalistic Compilations, Graphical Compilations, DPS Compilations, Healer Compilations, Generic Compilations
9.0.1

FreeUI <Continued>  Updated Today!  Popular! (More than 5000 hits)

Version: 9.1.2
by: devilArt [More]

FreeUI <Continued>

This is a personal edition of FreeUI, updated and heavily modified.
All credits should go to
Haleth and siweia for their amazing works.

More screenshots with better details.

Please report all issues on Github.


  • '/freeui' show available commands
  • '/freeui install' open install panel
  • '/freeui config' open config panel
  • '/freeui unlock' unlock UI elements to move them
  • '/freeui reset' delete all saved options data
  • '/rl' reload UI
  • '/rc' ready check
  • '/rp' role poll
  • '/lg' leave group
  • '/rs' reset instance

FreeUI
9.1.2 (2020-10-20)
Full Changelog Previous Releases
  • Merge branch 'develop' into Shadowlands
  • Update README.md
  • Update quest tracker
    右键点击任务追踪*的任务或者成就,可以获取wowhead的链接,方便查询详情,可爱的熊猫妹妹表示很需要这个功能 👌
  • Merge branch 'develop' into Shadowlands
  • Update unitframe and nameplate
  • Minor tweaks
  • Fix button style
  • Fix inventory money display
  • Fix unitframe issues
  • Fix garrison landing page
  • Cleanup
  • Minor tweaks
  • Remove default tooltip money string
  • Fix errors output
  • Cleanup fonts defines
  • Fix leave party command
  • Update .luacheckrc
  • Fix clickcast
  • Fix actionbar hotkeys
  • Minor fixes
  • Cleanup
  • Update fonts
  • Fix aura
  • Update chat module
  • Update quest module
  • Fix encounter journal
  • Tweak quest tracker fonts
  • Fix tooltip quality color
  • Fix text color
Optional Files (0)


Archived Files (14)
File Name
Version
Size
Author
Date
9.1.1a
2MB
devilArt
10-17-20 02:17 AM
9.1.0
2MB
devilArt
09-18-20 02:17 AM
9.0.9
2MB
devilArt
09-17-20 10:11 AM
9.0.8
2MB
devilArt
09-16-20 10:23 PM
9.0.7
2MB
devilArt
09-12-20 03:32 PM
9.0.6
2MB
devilArt
09-09-20 09:29 PM
9.0.5
2MB
devilArt
09-07-20 04:18 PM
9.0.4
2MB
devilArt
09-06-20 02:44 AM
9.0.3
2MB
devilArt
09-06-20 01:48 AM
9.0.2
2MB
devilArt
09-05-20 03:53 PM
9.0.1
2MB
devilArt
09-04-20 02:29 AM
9.0.0
2MB
devilArt
09-02-20 06:36 PM
9.0.0
2MB
devilArt
09-02-20 06:36 PM
80200.11
2MB
devilArt
09-30-19 02:55 PM


Post A Reply Comment Options
Unread Yesterday, 03:53 AM  
Zenjaa
A Deviate Faerie Dragon

Forum posts: 10
File comments: 53
Uploads: 0
would it be possible to add back the option to change between two different font styles for the ui.
like in a few versions before where you could switch between a normal and a pixel font.
Report comment to moderator  
Reply With Quote
Unread 10-18-20, 09:28 AM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
Originally Posted by Lucar
I don't know what happened but the settings menu doesn't work.

https://github.com/Solor/FreeUI/issues/57
Report comment to moderator  
Reply With Quote
Unread 10-18-20, 07:19 AM  
Lucar
A Defias Bandit
 
Lucar's Avatar

Forum posts: 2
File comments: 47
Uploads: 0
I don't know what happened but the settings menu doesn't work.

Report comment to moderator  
Reply With Quote
Unread 10-17-20, 05:48 PM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
Originally Posted by Dancingblade
Originally Posted by jakeface1
Originally Posted by Dancingblade
Originally Posted by jakeface1
With the latest update, it now works in prepatch. The only issue I have is the options are completely blacked out and I cant change anything. Were getting closer!
Weird.

It doesn't show up at all in the addons list in game for me. I've double-checked that it's in the addons folder. My other addons show up fine. I even deleted my Interface and WTF folders and tried a new install of it.

Issue with the TOC maybe?
Make sure you copy the FreeUI folder inside the folder you extracted.
Ok - somehow I had the FreeUI folder inside of another folder also called FreeUI in my addons folder. No idea how that happened, but your suggestion got me digging around and that fixed it. Thanks.
NP, I did the exact same thing lol
Report comment to moderator  
Reply With Quote
Unread 10-17-20, 05:19 PM  
Dancingblade
A Murloc Raider
 
Dancingblade's Avatar

Forum posts: 9
File comments: 48
Uploads: 0
Originally Posted by jakeface1
Originally Posted by Dancingblade
Originally Posted by jakeface1
With the latest update, it now works in prepatch. The only issue I have is the options are completely blacked out and I cant change anything. Were getting closer!
Weird.

It doesn't show up at all in the addons list in game for me. I've double-checked that it's in the addons folder. My other addons show up fine. I even deleted my Interface and WTF folders and tried a new install of it.

Issue with the TOC maybe?
Make sure you copy the FreeUI folder inside the folder you extracted.
Ok - somehow I had the FreeUI folder inside of another folder also called FreeUI in my addons folder. No idea how that happened, but your suggestion got me digging around and that fixed it. Thanks.
Report comment to moderator  
Reply With Quote
Unread 10-17-20, 02:30 PM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
Originally Posted by Dancingblade
Originally Posted by jakeface1
With the latest update, it now works in prepatch. The only issue I have is the options are completely blacked out and I cant change anything. Were getting closer!
Weird.

It doesn't show up at all in the addons list in game for me. I've double-checked that it's in the addons folder. My other addons show up fine. I even deleted my Interface and WTF folders and tried a new install of it.

Issue with the TOC maybe?
Make sure you copy the FreeUI folder inside the folder you extracted.
Report comment to moderator  
Reply With Quote
Unread 10-17-20, 01:31 PM  
Dancingblade
A Murloc Raider
 
Dancingblade's Avatar

Forum posts: 9
File comments: 48
Uploads: 0
Originally Posted by jakeface1
With the latest update, it now works in prepatch. The only issue I have is the options are completely blacked out and I cant change anything. Were getting closer!
Weird.

It doesn't show up at all in the addons list in game for me. I've double-checked that it's in the addons folder. My other addons show up fine. I even deleted my Interface and WTF folders and tried a new install of it.

Issue with the TOC maybe?
Report comment to moderator  
Reply With Quote
Unread 10-17-20, 10:08 AM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
With the latest update, it now works in prepatch. The only issue I have is the options are completely blacked out and I cant change anything. Were getting closer!
Report comment to moderator  
Reply With Quote
Unread 10-14-20, 01:49 PM  
Equelibrium
An Aku'mai Servant

Forum posts: 37
File comments: 29
Uploads: 0
FreeUI doesn't load with the new patch, and when you try to use /freeui config, it says you cannot use this action while in combat.
Report comment to moderator  
Reply With Quote
Unread 10-11-20, 01:07 PM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
Re: Re: Action Cam

Originally Posted by Equelibrium
Originally Posted by jakeface1
I'm not seeing a way to disable the action cam. Am I just missing this?
AFAIK there is no way in the FreeUI config to do it.
You can either do a '/console actioncam off' (only works until UI is reloaded) or you can edit the FreeUI.lua of your character and change '["action_camera"] = true' to '["action_camera"] = false'
Thanks I was doing the console command, but like you said it gets old. I'll do the change in FreeUI.lua, ty!
Report comment to moderator  
Reply With Quote
Unread 10-11-20, 02:51 AM  
Equelibrium
An Aku'mai Servant

Forum posts: 37
File comments: 29
Uploads: 0
Re: Action Cam

Originally Posted by jakeface1
I'm not seeing a way to disable the action cam. Am I just missing this?
AFAIK there is no way in the FreeUI config to do it.
You can either do a '/console actioncam off' (only works until UI is reloaded) or you can edit the FreeUI.lua of your character and change '["action_camera"] = true' to '["action_camera"] = false'
Report comment to moderator  
Reply With Quote
Unread 10-09-20, 01:15 PM  
jakeface1
A Kobold Labourer

Forum posts: 0
File comments: 15
Uploads: 0
Action Cam

I'm not seeing a way to disable the action cam. Am I just missing this?
Report comment to moderator  
Reply With Quote
Unread 10-02-20, 07:55 AM  
Floralux
A Kobold Labourer
 
Floralux's Avatar

Forum posts: 0
File comments: 3
Uploads: 0
Re: Re: Unitframes

Originally Posted by devilArt
Originally Posted by Floralux
Hello, I just installed this UI and I downloaded it from github since it sounded like that was the most up to date version. However after installing it I noticed the unitframes I don't believe are working like they should. It's still showing the default blizzard frames for me. Any way to fix this? I do have unitframes enabled as well.



Thanks!
see that "version:@project-version@"
these are unpacked develop files
you should download from here directly or github page right side release link
Ahh ok lol thank you for clarifying! I'll try the wowinterface version instead and see if I still have any issues. I appreciate the quick response. (:

ETA: Ok yeah that seemed to be the issue, works fine now lol.
Last edited by Floralux : 10-02-20 at 07:59 AM.
Report comment to moderator  
Reply With Quote
Unread 10-01-20, 03:37 PM  
Equelibrium
An Aku'mai Servant

Forum posts: 37
File comments: 29
Uploads: 0
Originally Posted by devilArt
I use weakauras for proc and cooldown, it's good at it.
Cool enough, but I'd really like to use the default ones. Is there a way I can re-enable them?
Report comment to moderator  
Reply With Quote
Unread 10-01-20, 02:59 PM  
devilArt
A Cyclonian
 
devilArt's Avatar
AddOn Author - Click to view AddOns

Forum posts: 47
File comments: 203
Uploads: 2
Re: Unitframes

Originally Posted by Floralux
Hello, I just installed this UI and I downloaded it from github since it sounded like that was the most up to date version. However after installing it I noticed the unitframes I don't believe are working like they should. It's still showing the default blizzard frames for me. Any way to fix this? I do have unitframes enabled as well.



Thanks!
see that "version:@project-version@"
these are unpacked develop files
you should download from here directly or github page right side release link
Report comment to moderator  
Reply With Quote
Post A Reply



Category Jump: