WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   Carbonite: Quests Module (https://www.wowinterface.com/forums/forumdisplay.php?f=160)
-   -   no quest complete sounds.... (https://www.wowinterface.com/forums/showthread.php?t=51972)

txamethyst 02-24-15 07:44 PM

no quest complete sounds....
 
when completing a quest or steps.

prior to today unchecking/checking the selection would play the sound. today nothing plays except for the carbonite quest complete and i don't use that one.

[email protected] 02-25-15 02:40 AM

No Quest Complete Sounds
 
It appears that most of the quest complete sounds are files in the game itself, which are either moved or deleted now, hence why they don't work anymore. The reason the Quest Complete sound works, is because it is an ogg file in the carbonite addon. I renamed my QuestComplete.ogg to a backup and copied in the quest complete audio that I wanted to play when I complete a quest and named it QuestComplete.ogg. Until such time that this gets resolved, I hope that this provides a simple workaround. Keep up the great work Rythal.

Svegan 02-26-15 10:04 AM

Fix posted
 
Change the .wav to .ogg in the nxoptions.lua file in the carbonite folder. I have posted an issue on github to let the developers know also.

rckann 02-26-15 09:16 PM

Quote:

Originally Posted by Svegan (Post 306974)
Change the .wav to .ogg in the nxoptions.lua file in the carbonite folder. I have posted an issue on github to let the developers know also.

I manually edited this file, and can confirm this fixes the problem. Thanks, Svegan!

jeffy162 02-27-15 06:23 PM

Yep, doing this definitely fixes the problem. Manually edit the "NxOptions.lua" file. The sounds you need should be on lines 4024 through 4031. Just change .wav to .ogg and you'll be good to go. You should use something like Notepad ++ to do it, but Windows Notepad works if you don't feel like downloading Notepad ++. Mac users know what to use.

Thanks much, Svegan.

nelegalno2 02-28-15 12:41 AM

Fixed by Rythal in b251b24

P.S. If you want to fix it manually you need to make the change in: Carbonite\NxMap.lua, Carbonite\NxOptions.lua & Carbonite.Social\NxSocial.lua

jeffy162 02-28-15 01:09 PM

Quote:

Originally Posted by nelegalno2 (Post 307072)
P.S. If you want to fix it manually you need to make the change in: Carbonite\NxMap.lua, Carbonite\NxOptions.lua & Carbonite.Social\NxSocial.lua

@ nelegano2: If that's so, then why do the sounds work if you only fix them in the "NxOptions.lua" file? If they're in those other files they apparently don't do anything there. Of course, I could always be wrong - they might do something and I've just never seen / heard it.

samyonair 02-28-15 03:10 PM

I think nelegalno2 means to have all functional the changes rythal made at github for wav problem

only can be solved if you change these three files, if you want only have your sound for quests back you can change only the nxoptions.lua

Greetings Samyonair

nelegalno2 03-01-15 03:55 AM

@samyonair, thanks.

@jeffy162, as samyonair said all 3 files use sounds for different purposes and thus should be fixed - unless you want only specific sounds available.

jeffy162 03-01-15 08:22 AM

Thank you both for your explanations. Now, I've got to say, I repaired the sounds in the other files that I found them in and now I don't have any sounds! BUT, I checked the options and they were turned off. Why? I don't know. I know that I didn't turn them off. This has been happening quite a bit for me. I'll set things up and the next time I play WoW they will either be back the way they were before I changed them or they will be disabled. That's just no fun. :D :o

nelegalno2 03-01-15 09:07 AM

That shouldn't be happening unless wow crashes (instead of exiting normally), you exit with Alt + F4 or there is a problem with you're HDD. Have you run checkdisk recently?

jeffy162 03-01-15 10:44 AM

WoW didn't crash and I don't exit WoW with "alt + F4". I haven't run the checkdisk utility on this computer yet because it's only 5 months old. This problem is something that has been on-going with Carbonite. I've had this problem for at least two years. In that time I have upgraded to a new computer but the problem persisted. I figure it's because I run so many addons. I regularly have about 100 addons. Seriously. Most are active on all of my characters, but not all of them are active on any one character. But the problem is there on Carbonite on all of my characters. It's no big deal and it is not a game breaker. I like Carbonite and continue to use it even though I have some nagging little problems with it (even on the PTR with ElvUI).


All times are GMT -6. The time now is 08:04 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI