WoWInterface (
-   Graphics Help (
-   -   Invisible icons. (

FranekW 05-26-19 02:00 PM

Invisible icons.

I tried to extend HandyNotes so that it would add extra icons to World Map. I downloaded a couple of other already made modules for HandyNotes. I decided to just slightly change HandyNotes_ToolsForTheTrade (link). I communicate with an author but he does not response.

Everything is almost good with one exception that my custom icons I decided to use are invisible / transparent. I have noticed the objects exist on the map because when I point over them I can see map responds correctly showing me tooltips with proper info etc. I can't understand why the icons are not shown.

I assume that path to the files is correct and points to an existing folder, e.g. `Interface\\Addons\\HandyNotes_ToolsOfTheTrade\\Icons\\orange_gem.tga`, the file format is correct, .TGA, and size is 32 pixels, with 1 alpha channel for transparency. I used the same files with another addon like core HandyNotes itself and they were displayed without problems. They don't seem to work with this module.

Any idea why wow does not display my icons?


jeffy162 05-26-19 03:19 PM

Check the size of the graphic. It might have gained a pixel on one side. I had that very same problem with one of my Masque plug-ins, and when I checked the graphics they had gained 1 pixel. I have no idea how, either.

And before I get a ton of "but that'll just give you a green box" comments, it didn't. The graphics were just not there. Found out they "grew" a pixel, resized them, and everything worked out.

FranekW 05-27-19 05:20 AM

I checked the size of files and they seem to be all right, 32 x 32, and I believe the problem must be somewhere else, like in the addon itself. I wonder if I should ask about it in a different section.

The addon uses stanbdard ACE-3 libraries including LibStab, HereBeDragon, and CallbackHandler. I am trying to alter something that uses a different way to me of pointing to icons to render. I don't even know what I should ask about. This addon uses a really convoluted way to get texture via function call of function call of function call which eventually calls GetAtlasInfo() with "atlas" as an input and returns a texture which is then trimmed.

Originally, the addon uses a few icons that author refers as "PortalRed", "worldquest-icon-tailoring", and "Garr_TreasureIcon". This does not looks like an internal icon names such as "INV_Jewelcrafting_80_Gem02_Blue" which refers to a blue gem. There are not extra tga/bpl files in an addon folder, either. I thought they would be in a HandyNotes (core) folder but there are not! I am completely lost here. It must miss something obvious, yet I don't know what it is!

I found it. The source of icons used in this addon is from `AtlasInfo.lua` (link to FrameXML). I finally managed to get textures from my own file and render them on map. That was quite an adventure :)

All times are GMT -6. The time now is 11:10 PM.

vBulletin © 2021, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI