WoWInterface (
-   OpenRDX: Bug/Error Reports (
-   -   Version: 10.0.7_alpha (

MNKyDeth 11-23-14 05:40 AM

Version: 10.0.7_alpha
I am really enjoying 10.0.7, many less visible issues that I am running into lately. Thanks Sigg.
However I did still get this Lua error, same one that I got in 10.0.6.

[string "local windowpath = "RDXDiskTheme:MD3:Player..."]:211: attempt to compare number with nil

Stack trace:
...erface\AddOns\RDX\Designs\Lists\HeaderAuraEngine.lua:161: in function <...erface\AddOns\RDX\Designs\Lists\HeaderAuraEngine.lua:161>


RDX: Window <RDXDiskTheme:MD3:Raid_Frame_Pet> caused a paint error.

Extended info:
Pointer: table: 00000000285E9F40
Identity: RDXDiskTheme:MD3:Raid_Frame_Pet
Path: RDXDiskTheme:MD3:Raid_Frame_Pet
[string "local windowpath = "RDXDiskTheme:MD3:Raid_F..."]:129: attempt to index field 'Texture_texparlera' (a nil value)

more ....

RDX: Window <RDXDiskTheme:MD3:Raid_Frame> caused a paint error.

Extended info:
Pointer: table: 000000002C2D3F70
Identity: RDXDiskTheme:MD3:Raid_Frame
Path: RDXDiskTheme:MD3:Raid_Frame
[string "local windowpath = "RDXDiskTheme:MD3:Raid_F..."]:129: attempt to index field 'Texture_texparlera' (a nil value)

This is using the sitrax buff indicator in the upper right of the screen I just copied it into my theme so I had something to work from.

The next thing I noticed is that I was doing a Molten Core level 100 run this past day and the first two battles in the instance I was DC'd. I am not for sure if this was an RDX issue or not but after reconnecting the game smoothed out and was playable. In my chat window I kept getting text saying that I was not in a raid or raid group. It was like an error because it kept repeating. Thought I would mention it though.

Edit 1:
I was using the default sitrax raid frames as well as I really enjoy those ones. The only change I made to them from the default setup was set periodic repaint on them. Same way since wotlk since I been using them. Also, on the sitrax raid frames the role icon does not change from a healing + symbol. I looked into it but everything seems normal to display roles, it just never changes to the proper role of people in my groups.

sigg 11-26-14 11:11 AM

4 Attachment(s)
Dear MNKyDeth

I need to view the generated code of your unitframes.

Please do this:

Enable the system to store unitframes code from the RDX settings

Go to the explorer, select the design of the unitframe, right click and select view compiled code

Copy the content of the page (Ctrl A then Ctrl C)

Past it in the file then send me your file

About the role icon, I am checking it.

MNKyDeth 11-26-14 11:17 PM

2 Attachment(s)
Here is the raidframe_d, I would assume it would be exactly like the one in the sitrax theme.

I should mention that I do use DBM and recount with openrdx. I don't think either of those addons would tell me I am not in a raid but I could be wrong.

Edit: Well, I had a similar issue in an dungeon 5 man. This happened once that I can recall and I have run a lot of 5mans. I guess since I am a bit familiar with a lot of the mechanics now I may get rid of dbm and disable recount so I can rule them out to help pinpoint what mod was/is causing the issue.

new attachment from a 5man with the spam I was talking about.

Another edit:
I did some thinking about the scenario on what I was doing when I was getting the chat spam. I was in a group outside of the instance. I then solo queued, so I was in the instance party and I was also in a party when not in the instance. Could that possibly be causing the issue?

sigg 12-10-14 11:29 PM

This is a very strange error

I added a check control in the code, joping it will fix the issue.

MNKyDeth 12-20-14 12:35 PM

I have tried to duplicate this error but have not been able to do so.

So I don't know if it was a Blizzard issue or what it was exactly. If it was a Blizzard issue they may have fixed it during one of the hotfixes.

I have been trying out more of the options and so far OpenRDX is doing what I want it to do without much issue now. I think I ran into an issue with my action bar setup again but I am going to put more time into that to make sure it's not something I did wrong with my Custom definition.

I have not really delved into the carbonite stuff yet, but may in the future.

One thing I would like to do is move the Quests (Objectives) window that is on the right hand side of the screen. This might be a feature request but I have not seen a way to move it around with OpenRDX.

MNKyDeth 12-27-14 07:24 PM

I wanted to give an update with a new post as an edit might get missed on an above post.

I was playing with the textures for the auras. Statusbar style option. I go into that selection and then click on bar texture and select Flat. I then want to change the color of the bar. So I want it to be green when it is full and red when it is empty. I put a check mark in the Use gradient option and set the colors as I want.

In the square window it shows me what it will look like and it looks correct. When I go to the game screen my bars still appear the default grey color. Not sure if I did it wrong or if that is a bug.

Edit 1:
This may be a suggestion but editing the icons options and setting the text size on the font stack or cooldown text I would like to go bigger than 20. Maybe up to 24 or 32 if it is even possible.

Another problem I have found, I thought it might be a problem with the custom action bar settings I was using but I have not been able to figure out why it does it. So I am going to put my custom settings here for you.

I use 3 action bars on my screen. When I am in my primary spec of feral kitty, everything is fine no issues. My offspec is Balance. I use the same bars for both specs. So here are the definitions for each bar.

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:3] 4; [bonusbar:1,stealth] 8; [bonusbar:1] 6; [vehicleui] 11; [possessbar] 11; [overridebar] 13;

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:3] 4; [bonusbar:1] 6;

[bonusbar:4] 10;

What happens is that when I shapeshift into moonkin form the bar goes blank. If I do a Reload UI the icons come back and are usable while in moonkin form. But if I shift out of moonkin form and then back into moonkin form they icons dissapear again, and a reload ui is needed. I do not get any LUA errors. I have tried setting defaultUI for this bar on bonusbar4. But using this bar as Bar Id bonusbar4 seems to work fine for everything except moonkin. I don't have any problems on other toons like my mage or shaman so not sure if it my bar settings or a problem with the mod.

I guess I should mention as well that I use Bar1 bar id as mainbar1. And Bar2 bar id is mainbar2, Bar3 is the only bar I use as bonusbar4.

All times are GMT -6. The time now is 10:10 AM.

vBulletin © 2021, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI