WoWInterface (
-   Lua/XML Help (
-   -   MoveAnything: Action[SetPoint] failed ActionButton2:SetPoint (

nToxik 03-21-20 09:58 PM

MoveAnything: Action[SetPoint] failed ActionButton2:SetPoint
Hey guys, fixed one error and this new error cropped up. I keep going into MoveAnything to reset the Action Button but the reset never holds and I keep getting this error. Any ideas? I hope this is the best place to post this.


3x Action[SetPoint] failed because[SetPoint would result in anchor family connection]: attempted from: ActionButton2:SetPoint.
[string “=[C]”]: ?
[string “=[C]”]: in function SetPoint' [string "@MoveAnything\VirtualMovers.lua"]:1626: in function OnMAReleaseChild’
[string “@MoveAnything\MoveAnything-17.1.0.lua”]:5949: in function ReleaseChild' [string "@MoveAnything\MoveAnything-17.1.0.lua"]:6211: in function OnMAPreReset’
[string “@MoveAnything\API.lua”]:322: in function Reset' [string "@MoveAnything\API.lua"]:243: in function <MoveAnything\API.lua:219> [string "=(tail call)"]: ? [string "=[C]"]: ? [string "@MoveAnything\MoveAnything-17.1.0.lua"]:1294: in function SyncFrames’
[string “@MoveAnything\MoveAnything-17.1.0.lua”]:1265: in function `SyncAllFrames’
[string “@MoveAnything\MoveAnything-17.1.0.lua”]:5833: in function <MoveAnything\MoveAnything.lua:5435>

Xrystal 03-22-20 12:18 AM

That is one of the new changes Blizzard introduced in BFA. Anchors have a family system. I don't understand it fully but this error usually means that you aren't allowed to anchor it to the frame you are currently using. You would have to look through the frame hierarchy I suspect to find out the reason for that and to identify an alternative.

nToxik 03-22-20 08:47 PM

Yeah thanks. I'm just not sure how to un-anchor it. I thought resetting it would do that but it keeps coming back. I've hit every reset button and I've also disabled it and unregistered all events but I still get the error.

Strata is medium at the moment. Honestly, I don't think I ever intentionally moved this Action Bar before.

Xrystal 03-22-20 09:01 PM

Which version of MoveAnything are you using ?

It appears to be up to date ( Jan 2020 ) on Curse which should have got rid of any errors like this when it was first released for the expansion.

However, I can see from the bug reports that the same error you are seeing has been reported there.

Worse case Scenario is that the changes introduced by Blizzard this expansion has made addons like MoveAnything not viable anymore. However, nUI has mover frames for most frames and I only came across one of these errors and no amount of research/code changing would resolve it, so I took that element of nUI out of the equation for the time being.

For your reference to when this error was first noticed by myself ...

It highlights different scenarios which triggers the error and other similar scenarios which don't.

nToxik 03-22-20 09:20 PM

Yeah i'm using the latest version of MoveAnything from January 2020. I did have a different error prior to this one with the FPS frame (which I never intentionally move) and fixed that one by resetting the frame in MA. Bu this error creeped up the next day.

I've tried deleting MoveAnything as well as deleting saved variables but the error seems to come back. I wonder if this is being caused by a different addon and then it gets reported as a MoveAnything error for some reason?

Xrystal 03-23-20 04:11 AM

Yes that is always possible. Try the addons one at a time and see if any one single addon triggers the error. If it doesn't add them one at a time until it triggers then start over with just that one addon and add each addon and see if it triggers with one of them. If it doesn't it could involve more juggling of addons to track down which combination causes the issue but these steps would be the quickest and more direct route.

All times are GMT -6. The time now is 06:43 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI