WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   Lua/XML Help (https://www.wowinterface.com/forums/forumdisplay.php?f=16)
-   -   Change HighlightFont (https://www.wowinterface.com/forums/showthread.php?t=57599)

Zam89 10-13-19 11:22 AM

Change HighlightFont
 
Hi,

how can I Change the "HighlightFont" which is set in the XML in lua?

In XML: <HighlightFont style="GameFontHighlight"/>

Need to Change the HighliteFont for a Default Blizzard button into black

Thanks.

SDPhantom 10-13-19 12:15 PM

Code:

local highlight=Button:GetHighlightFontObject();
highlight:SetTextColor(0,0,0);

Note: If you're not doing anything else with the FontString, you can do this instead.
Code:

Button:GetHighlightFontObject():SetTextColor(0,0,0);

Zam89 10-13-19 12:51 PM

Thanks.

But the text is changing into White:

THis is the Blizzard Code:

Code:

<Button name="StaticPopupButtonTemplate" virtual="true">
                <Size x="128" y="21"/>
                <Animations>
                        <AnimationGroup parentKey="PulseAnim" looping="BOUNCE">
                                <Alpha childKey="Flash" fromAlpha="0" toAlpha="1" duration="0.5" order="1"/>
                                <Alpha childKey="Flash" fromAlpha="1" toAlpha="0" duration="0.5" order="2"/>
                        </AnimationGroup>
                </Animations>
                <Layers>
                        <Layer level="OVERLAY" textureSubLevel="1">
                                <Texture parentKey="Flash" file="Interface\Buttons\UI-Panel-Button-Glow" alphaMode="ADD" alpha="0">
                                        <Size x="140" y="40"/>
                                        <Anchors>
                                                <Anchor point="CENTER"/>
                                        </Anchors>
                                        <TexCoords left="0.0" right="0.75" top="0.0" bottom="0.609375"/>
                                </Texture>
                        </Layer>
                </Layers>
                <Scripts>
                        <OnClick>
                                StaticPopup_OnClick(self:GetParent(), self:GetID());
                        </OnClick>
                </Scripts>
                <ButtonText name="$parentText">
                        <Anchors>
                                <Anchor point="CENTER">
                                        <Offset x="0" y="1"/>
                                </Anchor>
                        </Anchors>
                </ButtonText>
                <NormalTexture file="Interface\Buttons\UI-DialogBox-Button-Up">
                        <TexCoords left="0.0" right="1.0" top="0.0" bottom="0.71875"/>
                </NormalTexture>
                <PushedTexture file="Interface\Buttons\UI-DialogBox-Button-Down">
                        <TexCoords left="0.0" right="1.0" top="0.0" bottom="0.71875"/>
                </PushedTexture>
                <DisabledTexture file="Interface\Buttons\UI-DialogBox-Button-Disabled">
                        <TexCoords left="0.0" right="1.0" top="0.0" bottom="0.71875"/>
                </DisabledTexture>
                <HighlightTexture file="Interface\Buttons\UI-DialogBox-Button-Highlight" alphaMode="ADD">
                        <TexCoords left="0.0" right="1.0" top="0.0" bottom="0.71875"/>
                </HighlightTexture>
                <NormalFont style="GameFontNormal"/>
                <DisabledFont style="GameFontDisable"/>
                <HighlightFont style="GameFontHighlight"/>
        </Button>


And this is what I have done with the button:

Code:

_G["StaticPopup" .. i .. "Button" .. ii]:SetNormalTexture("Interface\\AddOns\\GW2_UI\\textures\\button")
                _G["StaticPopup" .. i .. "Button" .. ii]:SetHighlightTexture("Interface\\AddOns\\GW2_UI\\textures\\button")
                _G["StaticPopup" .. i .. "Button" .. ii]:SetPushedTexture("Interface\\AddOns\\GW2_UI\\textures\\button")
                _G["StaticPopup" .. i .. "Button" .. ii .. "Text"]:SetTextColor(0, 0, 0, 1)
                _G["StaticPopup" .. i .. "Button" .. ii]:GetHighlightFontObject():SetTextColor(0,0,0)
                _G["StaticPopup" .. i .. "Button" .. ii .. "Text"]:SetShadowOffset(0, 0)
                _G["StaticPopup" .. i .. "Button" .. ii .. "Text"]:SetDrawLayer("OVERLAY")

But when I hove the Button the button Color Changed to White:

Image

But it should stay black

Xrystal 10-13-19 10:22 PM

Ignore the following if you did mean the font itself and not the image.


It looks like someone years back had a similar problem and posted the query on another site and got an answer ..

https://www.mmo-champion.com/threads...-on-mouse-over

This is the actual line of code to change the color of the image .. set these to 0,0,0 for black
button3:GetNormalTexture():SetVertexColor(r, g, b);

What you changed in your code to 0,0,0 is the font text and not the image itself. So you may want to revert that back to what it was so that you can see the writing properly.

Give that a go and let us know how you eventually got it working ( if you did that is )

Zam89 10-14-19 01:19 AM

Thanks, that was the perfect hint :)
Added the vertex color and add a Owen onenter and in leave script.

Works perfect :)


All times are GMT -6. The time now is 11:37 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2019 MMOUI