WoWInterface (
-   General Authoring Discussion (
-   -   Installation Requirements (

Nulkris 10-01-05 07:06 PM

Installation Requirements
Installation Requirements

Links to required files:

Windows Installer 3.1 - required to install the .NET 2 redistributable, that link requires genuine Windows validation.
Microsoft .NET Framework Version 3.5 SP1 Redistributable Package (x86)
Microsoft .NET Framework Version 1.1 Redistributable Package - may be required if Lua interface does not work correctly.


1. Install all latest service packs.
2. Install Windows Installer 3.1
3. Install Microsoft .NET 3.5 SP1 Release redistributable
4. Ensure that a copy of World of Warcraft is installed correctly on your system. Use regedit.exe to check HKEY_LOCAL_MACHINE/SOFTWARE/Blizzard Entertainment/World of Warcraft/InstallPath to see if you have a good install. You can change the path in the wowuides program options later, but this reduces the problems.
5. Run WoW UI Designer v1.1.X.msi to install the program.
6. Incase of problems, install the Microsoft .NET Framework Version 1.0 Redistributable Package (plus all service packs) and Microsoft .NET Framework Version 1.1 Redistributable Package.

If you are installing over a previous version, make sure that you either uninstall if you have the option, or delete the *.exe and *.dll files in the directory.

Cairenn 10-01-05 08:33 PM

Well, installation was a breeze. Now to play!

neriak_x 10-02-05 06:35 PM


I've tried as hard as I could, but the wowuides.exe doesn't run on my machine. I've installed every requirements, checked the reg, run the Interface Kit and extracted the fonts but I get a non-saying MsgBox: Microsoft has found an error, blabla closing. (I don't know the english one, since my Windows is German).

I'm running WinXP Pro SP2 on an AMD 1600+, 1GB SDRAM, ATI Radeon 9600 256 MB. This is a rather new and clean Windows installation, so now I'm absolutely clueless. The Errorlogs didn't find any Issue regarding your application.

Oh yes, I also installed the Alpha Patch, of course.

Spew 10-05-05 11:28 AM

I needed the 1.1 .Net Redist, and after that it installed just fine.

Mirium 10-30-05 01:14 PM

Ok, I must have, at some point, installed the WoW custom Interface kit then deleted the files. Now when I try to reinstall it it says it's already installed and refuses to go further. Anyone know how to fix this?

Nulkris 10-31-05 03:08 AM

Sorry, I've been out all day. You need to delete everything in the [wow]/Interface directory except for your Addons directory. Also, if you have installed the test version, then you will need to delete everything in [wow]/wowtest/interface except the addons. Then it should work.

zhuchong530 11-21-05 04:31 AM

I'm Chinese!
my windows is chinese
It's Windows 2000 Advanced Server
May I use it on my Operation System?
Thank you~

mercdev 12-07-05 04:30 PM


Originally Posted by zhuchong530
I'm Chinese!
my windows is chinese
It's Windows 2000 Advanced Server
May I use it on my Operation System?
Thank you~

Yes - Be sure to install the Microsoft .NET Framework Version 2.0 Redistributable Package (x86), as well as the Microsoft .NET Framework Version 1.1 Redistributable Package if you haven't already done so.

Kaaosa 01-09-06 03:42 AM

Alright, I followed the instructions by the letter and when I start up WoW UI Designer I et a bunch of errors, mostly Frame XML errors, and the toolbox is empty. Is there something I've overlooked?

Oh, most of the errors are in the form of:
Inherited frame X not found

where X is several things, including UIPanelButtonTemplate, UICheckButtonTemplate, and UIPanelCloseButton. Ther eare several other frames mentioned in the same type of error.

Nulkris 01-09-06 04:56 AM


(i.e. Uncheck Validate Blizzard files against the Schema)

Climax 01-11-06 01:50 PM

A prob
Hey, thnx for the program but i have a little prob i followed everything how to install but when i started it up i didnt found anything :confused:

I made a link to a screenshot of the problem so you can see wat the problem is.

link to screenshot :

hope you can help me out

Nulkris 01-11-06 04:09 PM

Uncheck verify Blizzard files against the schema (as above your post).

Climax 01-12-06 12:42 AM

still a prob
ok i tunred the bliz xml files off and reloaded the addons but still he doesnt found them. it still doesnt work am i doing something wrong?

Climax 01-12-06 12:48 AM

nevermind that last post it worked! :) i dont what i did but i just clicked on the interface map and it reloaded everything now it works :)

CommanderSirow 01-14-06 05:50 AM

Installation Problem:
Sorry to disturb, but since WoW UI Designer v1.0.200.X (Beta and nightly versions) I can't install UI Designer any more, version works perfektly when installing, but as of all versions after I get the following error message, when starting the *.msi file:


This installation package could not be opened. Contact the publisher of this package and ask him, if this is a valid installation package.
(I LOVE microsoft error-messages :confused: )
(Error message translated from german to english, so it can differ a bit ;) )

Running Windows XP Proffesional SP1, german edition...
Also installed:
- Windows Installer 3.1
- Microsoft .NET Framework Version 2.0 Redistributable Package (x86)
- Custom Interface Kit
- WinMPQ
(- Microsoft .NET Framework Version 1.1 Redistributable Package [Told be allready installed, think I installed it allready])

[Possible, that you could also offer files in a *zip/*.rar archieve?]

Mr_Vonhelding 02-28-06 12:01 PM

I am unable to get this to load either.

Followed all the steps.
Installed all the items.
unpacked all teh files.

When I click the Icon in th start menu all i get is the Windows error BING! and nothing.
Im eager to get into mod design and this tool looks amazingly helpful.

Any suggestions why it might not even be loading up on my machine?

All times are GMT -6. The time now is 11:46 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI