WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   Carbonite: Maps (Main AddOn) (https://www.wowinterface.com/forums/forumdisplay.php?f=119)
-   -   Carbonite Minimap loses zoom when exiting indoors. (https://www.wowinterface.com/forums/showthread.php?t=56529)

CedricDur 08-12-18 01:51 PM

Carbonite Minimap loses zoom when exiting indoors.
 
It's a very recent thing. Whatever zoom I have the minimap at it loses it when I exit an indoor place and I need to zoom back, but it happens again the next time. There are no LUA errors.

I've done the usual deleting of variables, cache and reinstalling the alpha.


https://imgur.com/a/jt0gLkR

jeffy162 08-12-18 02:24 PM

Just out of curiosity - have you right clicked on the minimized map and chose the "Save scale" option in the pop-up menu?

I have to apologise here as it's been two years since I played WoW, and it's looking like I won't ever have the chance to play again.

CedricDur 08-12-18 03:12 PM

I did, yes. And the lost zoom is easily fixed by right clicking and choosing 'restore map scale'. But, we come in and out of indoor places a -lot- and the minimap is close to useless when zoomed in so close.

The 'indoors' has to be a cave of sorts though, it does not happen if we just enter a house. The indoors docking map needs to appear.

jeffy162 08-12-18 09:14 PM

I'm still curious - why do you have the Blizzard minimap "docking"? That could actually be causing your problem.

I remember having the same trouble with the minimized map about three years ago (it could be longer ago, but my memory isn't all that sharp anymore :o ). I cured it, I think, by making the minimap go full size inside. It is (or was) part of the options for the minimized map. Once I did that, I didn't have that particular problem again.

CedricDur 08-13-18 02:28 AM

Because I found that the indoors carbonite minimap is not very accurate. If we are inside a cave, for example, it does not show the herbalism or ore nodes. A minor nitpick easily solved by docking the Blizz minimap.

This arrangement has worked fine up to now but now that you mention it I will do a quick hop in-game to test.


Okay, went and tested. No option seems able to -remove- the docking. Which seems interesting.

https://imgur.com/a/lsHofT0


After a bit of testing it only happens when the indoors has a map of its own. A simple cave or house will not trigger this (though it -will- display the docked mini map), but if the map has to change to display the indoors area then when we pop back out the zoom is maxed.

I would say it is maybe just me since no one else is complaining about this, but I disabled all addons other than Carbonite Maps and had the same behavior repeating itself.

Edit: With all this testing I remembered why the carbonite minimap did not show the ore and herbal nodes while indoors. I have never been able to remove the indoors docking and the second best thing was to scale the docked minimap to a pinprick so it was for all effects invisible. But once docking happens it takes over showing the quest givers and the nodes, so even scaled down to a minimum it was taking over those duties.

CedricDur 08-13-18 07:33 AM

After blundering like a caveman in modern times I managed to make the docked minimap go away by commenting line 265 in NxMap.lua which just created a bunch of errors, but the loss of zoom remains once leaving an indoors place, like for example the cave where we save the sleeping druids during the Val'sharah questline.


All times are GMT -6. The time now is 08:32 PM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI