WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   Legion Beta archived threads (https://www.wowinterface.com/forums/forumdisplay.php?f=177)
-   -   Zombie buff icons on nameplates (https://www.wowinterface.com/forums/showthread.php?t=53462)

lieandswell 05-18-16 06:38 PM

Zombie buff icons on nameplates
 
In the Blizzard_NamePlates UI, recently seen buffs/debuffs are sometimes showing up on units that don't actually have them. To reproduce this, I've been turning both friendly and enemy nameplates on, going to the Orgrimmar training dummies, loading them up with debuffs, and then moving the camera around. You start seeing the debuffs on friendly players' nameplates. The "zombie" buffs don't go away when you turn nameplates off and on again (using V or shift-V).

zork 05-20-16 06:10 AM

It can happen if they forgot to reset the aura buttons of the nameplate.

Nameplates get reused thus once onhide fires (you turn your camera and the nameplate disappears from screen) or when the related guid changes they should wipe all unit-related nameplate tables.

You may be able to fix it yourself. Hook the OnHide event of each nameplate and make sure to wipe the nameplate aura table and hide all aura buttons. Currently not sure how they handle guids.

I did something similar in WoD when I implemented aura buttons on my own nameplates for the first time:
https://github.com/zorker/rothui/blo...lates.lua#L464

According to:
https://github.com/tomrus88/Blizzard...lates.lua#L326

Sth like this might do the job when called OnHide.
Lua Code:
  1. if not self.buffList then return end
  2. for key, value in next, self.buffList do
  3.   self.buffList[key]:Hide()
  4. end
What may cause the bug is that nameplates use their own buff icons and thus are not affected by CompactUnitFrame_UpdateBuffs which should trigger once a nameplate is shown.


All times are GMT -6. The time now is 03:56 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI