WoWInterface

WoWInterface (https://www.wowinterface.com/forums/index.php)
-   AddOn Help/Support (https://www.wowinterface.com/forums/forumdisplay.php?f=3)
-   -   How to access DisplayIDs without the use of Wowhead? (https://www.wowinterface.com/forums/showthread.php?t=56060)

Kaleesh 02-20-18 10:57 PM

How to access DisplayIDs without the use of Wowhead?
 
So, I need the DisplayIDs of old models in order to display them using different skins rather than just having a blank white model. I've found a great framework in PowerAuras, but the list file is manually created and does not include what I am looking for.

I know the usual method for obtaining DisplayIDs is using Inspect Element on Wowhead models, but the thing is, once models are updated ingame, Wowhead follows suit.

Is there any other way to find DisplayIDs? I've been poking around in WoW Model Viewer, but haven't been able to puzzle it out.

To be more specific, I am taking mobs with model updates that I dislike and making it so that they use their old models as unit portraits. Right now I'm working on Ghouls. Power Auras does have both variations of Ghoul, but the old model only has one skin with the option to change it greyed out (A strange anomaly considering all other avenues of displaying the old Ghoul model have no skins), while the updated model has something like twenty, with many repeats. It is almost as if the old ghoul skins were overwritten or no longer path to the old skins, but if this were true, I wouldn't be able to bring up the older Ghouls in WoWModelViewer, which I can.

Strangely enough, the model listed as the new one for Powerauras is "creature\\ghoul\\ghoul.m2", while WoWModelViewer differentiates ghoul.m2 as the old model, and ghoul2.m2 as the new one. If I add ghoul2.m2 to Power Auras' list file, it comes up as an error cube. I can't explain any of that either.

zork 02-21-18 12:10 PM

When I was looking for models I wrote an addon. https://github.com/zorker/rothui/tre...ameModelViewer

Being said. I just tested and updated it. Needed some updates for 7.3.5

For more read http://www.wowinterface.com/forums/s...ight=DisplayID

Here the the saved list from Resike before Legion:

https://raw.githubusercontent.com/Re...%20(21742).lua

Kaleesh 02-21-18 08:02 PM

Thank you, zork! I did try using your addon before now, so thank you for updating it.

I do still seem to be having the same problem, though. Just like with PowerAuras, your addon displays all new models except for one. As it turns out, that one usable old Ghoul model is ghoulnobirth.m2, whose only skin is the white variant. Ghoul.m2 does not point to the old models at all-- even though WoWModelViewer can access the old model and its attached skins through ghoul.m2 just fine.

Even the very oldest displayIDs such as 137 point to the new models now.

Every single one of the DisplayIDs from Resike's list (besides the ghoulnobirth) now points to the new models (again, paradoxically without using ghoul2.m2; the list file designates them as still using ghoul.m2), save for a few that display nothing at all.

I tried fiddling around with the way the PowerAuras list file associated certain DisplayIDs with certain models, switching ghoulnobirth with ghoul to see if that granted it use of more skins, but that didn't change anything. It seems not to matter which model is associated with which DisplayID. I suppose they were just listed that way to organize the dropdowns. :rolleyes:

I just don't have the know-how to differentiate how the WoW client and the modelviewer program display these things. Perhaps the client has some kind of impassable, automatic replacer set up...

Apologies if any of this is elementary (As I am sure it is); much as I've tried to learn about this stuff, I am just not good at it, and it is surprisingly hard to find information on what all of these terms are that doesn't assume you already know a whole lot.

Resike 02-22-18 08:29 AM

I'll update my table and see what happens, but i have a strong feeling that Blizz overwritten the old ghoul models with the the new ones (at least in their DB files), since i had a project with ghoul models and here you can see the old vanilla ghouls had the 137, 414, 519, 547 DisplayIDs and now those only point to the new ghoul model and skins:

https://github.com/Resike/PlantsVsGh...ls.lua#L97-L98

Resike 02-22-18 07:33 PM

Okay, the new model data can't be extracted since the game DB files only contain the first ~11k creature displayIDs, and the table also seems like inaccurate.

TOM_RUS 02-28-18 07:38 AM

Quote:

Originally Posted by Resike (Post 327017)
Okay, the new model data can't be extracted since the game DB files only contain the first ~11k creature displayIDs, and the table also seems like inaccurate.

That's not true.

https://gist.githubusercontent.com/t...ureDisplayInfo

Kaleesh 03-01-18 01:50 AM

Quote:

Originally Posted by TOM_RUS (Post 327081)

Gosh... Thanks loads, but is there any way to make this more... usable?

Other than typing tens of thousands of IDs in one at a time to see what I get, I mean.

Resike 03-01-18 10:44 AM

Quote:

Originally Posted by TOM_RUS (Post 327081)

I'm confused then why is my db file incomplete? Or you just used some other sneaky hack?
I could turn the table into an usable one, but i would prefer a retail live table, if you could share that one.

I'm also interested how can you know when do a "race-gender" pair should point to a HD version of a character model or a standard one, since if you mix those the associated model/skin be messed up.

TOM_RUS 03-01-18 01:28 PM

Quote:

Originally Posted by Resike (Post 327089)
I'm confused then why is my db file incomplete? Or you just used some other sneaky hack?
I could turn the table into an usable one, but i would prefer a retail live table, if you could share that one.

No idea. Data is in db2 files CreatureDisplayInfo, CreatureModelData and CreatureDisplayInfoExtra (for character based npcs), be it live or alpha.

Quote:

Originally Posted by Resike (Post 327089)
I'm also interested how can you know when do a "race-gender" pair should point to a HD version of a character model or a standard one, since if you mix those the associated model/skin be messed up.

There's some checks in place for if given race has HD model or not and if HD npc texture is available or not. Based on availability of HD model and HD texture you can load either or even both...
Edit: Oh and there's actually a link to modelId for char based npcs as well, but my tool ignores it and uses logic I just explained...

Resike 03-01-18 02:05 PM

Quote:

Originally Posted by TOM_RUS (Post 327090)
No idea. Data is db2 files CreatureDisplayInfo, CreatureModelData and CreatureDisplayInfoExtra (for character based npcs), be it live or alpha.



There's some checks in place for if given race has HD model or not and if HD npc texture is available or not. Based on availability of HD model and HD texture you can load either or even both...

Okay the problem is in the DB editor i used then (WDBX), what do you use to open it properly?

TOM_RUS 03-01-18 02:40 PM

Quote:

Originally Posted by Resike (Post 327091)
Okay the problem is in the DB editor i used then (WDBX), what do you use to open it properly?

I just tried it and there's seems to be no issues? Data looks the same as on my private tools (only tried 8.x, not live).

Resike 03-01-18 02:49 PM

Quote:

Originally Posted by TOM_RUS (Post 327092)
I just tried it and there's seems to be no issues? Data looks the same as on my private tools.

Edit: I found the problem, it's my bad.

TOM_RUS 03-01-18 02:59 PM

First look at CreatureDisplayInfo, find ModelId, then look at CreatureModelData for Id=ModelId and find FileDataId. For example: CreatureDisplayInfo.Id=26 -> CreatureDisplayInfo.ModelId=8379 -> CreatureModelData.Id=8379 -> CreatureModelData.FileDataId=1139464.

Resike 03-01-18 05:28 PM

Quote:

Originally Posted by TOM_RUS (Post 327094)
First look at CreatureDisplayInfo, find ModelId, then look at CreatureModelData for Id=ModelId and find FileDataId. For example: CreatureDisplayInfo.Id=26 -> CreatureDisplayInfo.ModelId=8379 -> CreatureModelData.Id=8379 -> CreatureModelData.FileDataId=1139464.

Thanks, I'll create a new model table tomorrow.

Resike 03-03-18 11:00 AM

Merged into my BlizzardInterfaceResources repo for 7.3.5 (26124):

https://github.com/Resike/BlizzardIn...ayPath.lua.txt


All times are GMT -6. The time now is 06:57 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI