WoWInterface (
-   Carbonite Archive (
-   -   Game locks up every time quest objectives update (

RonusX 08-02-13 12:58 PM

Game locks up every time quest objectives update
Hi, long time user and lover of Carbonite but i have been having some issues for the last few builds that i wanted to bring up and see if there is a easy fix that has somehow escaped me, or if it is something that needs to be addressed on the code level.

Everytime that a quest objective updates, such as loot a quest item, kill a mob and so on, my game client completely freezes up for about 1 sec, i have noticed that if i am in a party with my wife who also has carbonite(but not this problem), whenever a quest objective updates for her i also freeze, it makes it practically impossible to run together because i will be constantly freezing as we quest. i am using the latest beta, have disabled all other addons, and have done a complete reinstall/setup and it still happens. i'm not sure if there is a problem in the quest module or if the quest data is being improperly handled somehow. hopefully someone has encountered this before and can help me out

RonusX 08-08-13 07:32 PM

So i updated to 5.3.0 Alpha 2 and am still having the same problem, has anybody else experienced this or found a fix for it? Having to turn off the quest module really takes away some of the great functionality of the addon.

Chmee 08-09-13 07:45 AM

Sounds like a communication issue.

Rythal 08-09-13 10:17 AM

if it was only when grouped I could see that... but since it's happening to him solo aswell i'm not sure. while the quest log window is delayed in it's updates, it shouldn't be causing a full client lockup... and with no errors or bug reports I really can't say what could be causing it

Is it happening for your wife aswell? or just yourself... and do you have bugswatter or some other lua error catching installed / enabled? can you install them to see if anything comes up?

webchaos 08-09-13 08:43 PM

Same for me. Everytime i get a new quest or any quest objective is updated the game locks for a second. Unfortunately there is no errormessage coming up in swatter. When i disable the quest module everything works fine. I tried to disable all other addons, but the error remains.

Edit: For me the problem exists only on my lvl 90 char. Actually questing with my alt on lvl 37 in western plaguelands works well with no locks.

RonusX 08-11-13 04:25 PM

thanks for responding, it only happens on mine, and there are no errors at all that i can find, it is delayed by about 1 sec before it freezes so i don't know if that's relivent to helping figure out what's going on. if there is any info i can give you to help track down the issue let me know

Mnementh 08-12-13 06:56 AM

Definitely not limited to 90 lvl toons for me, it locks up on both my wife & I on any level. No errors caught here either.

RonusX 08-16-13 05:34 AM

well at least it's not just me being crazy and this is actually happening to others as well. Does anyone have a idea on what could be done to stop this, i love Carbonite but with the new patch soon and the new Xpac to follow i need a quest addon that i won't freeze up after anything updates.

RonusX 08-22-13 01:59 AM

has anyone found a solution for this yet or should i start looking for a different quest addon?

Vis 08-22-13 05:38 AM

I apologize for the Wall O Text ahead of time, lol.

Back when I used to rely on Carb I had a similar issue with the game stuttering here and there, mostly on updates like objectives status etc. I don't recall exactly what fixed it, but I do have a couple of generic suggestions for you to try. At the least, you may reduce your overhead of addons. At best, you may find the issue.

1. In your WoW directory, delete the folder named Cache. It's 100% safe to delete. All it holds is basic information that gets re-downloaded from Blizz servers as needed.

2. Do a fresh, clean install of Carbonite. That means delete all the Carbonite folders within the WoW\Interface\Addons folder. It also includes removing all of the Carbonite files within the WTF folder.

2a. My personal preferred method to find out if its the addon itself or an interaction issue with another addon is to start 100% from scratch on everything. Make a folder on your hard drive and name it something simple, mine is usually named "WoW_Backup". Then go into your WoW folder and Cut the "Interface" and the "WTF" folders and Paste them into the "WoW_Backup" folder.

I usually load WoW with zero addons at least once after all this just so I can setup sound, video, etc game settings to my liking.

Now comes the fun and time consuming part, install only Carbonite, set it up to your liking and see if you still stutter. If you don't, then it's possible you had a corrupted file somewhere or a possible addon conflict.
If you do stutter, then you know its something to do with Carb and only Carb simply because it's the only addon installed.

After all this, then you can start one by one re adding any other addons you may use. If you suddenly have stuttering after installing an addon then you've found the conflicting addon.

Kind of a lengthy process if you use tons of addons, but it's also a good time to trim down the number of ones you actually do use vs just have because of never removing them :)

RonusX 08-22-13 10:10 PM

Thanks Vis,
the "Wall O Text" is appreciated, sometimes the most simple solution evades us, so i went and did a full uninstall wiped everything and started from scratch(it was a great time to trim down the number of unused addons), started by re installing a new copy of Carbonite..and did not have the freezing. i then went and started the lengthy process of installing new copies of all my addons one at a time untill i found the problem. i use the addon PetTracker, and one of the things that it does is put the pets that you haven't collected in a zone into the Blizzard quest track window, for whatever reason when i have that installed and the Blizzard quest track window showing, it makes me freeze, if i disable PetTracker all together, or use carbonite to hide the Blizzard quest track window(Carbonite>quest module>watch options>Hide Blizzards quest track window) but leave PetTracker enabled the freezing stops. Unfortunately PetTracker doesn't integrate with the carbonite quest watch so i have to loose that function, but that's a small price to pay to have carbonite working again. Vis I appreciate your help, i don't know why that didn't occur to me, it's tech support 101, restart and reinstall. Rythal thank you for all the time and hard work that you put into developing and maintaining carbonite, i know that i for one would have a far less enojyable game experience if it wasn't for your effort.

Vis 08-23-13 04:50 AM

Glad you got it all sorted out and everything working smoothly again.

An alternative for you since you mentioned using PetTracker. I have that addon also but I dont use the QuestTracker list for it. Jaliborc, the author of PetTracker, has also made a plugin for LDB displays so that you can see at a glance how many pets you're missing in the current zone. When you mouseover the number shown, a tooltip appears giving you the full list for that zone with names etc.

Here's the link so you can take a look PetTracker - Broker

RonusX 08-24-13 08:37 PM

i actually tried that once i figured out what the problem was, but as soon as i put the plugin in a broker bar the same thing happens and i keep freezing, i found that if i turn off the zone tracker feature the freezing stops, so now i just turn it on in a zone to see what pets i still need and then turn it right back off and everything seems to work fine. Still not sure what is causing the conflict but it seams that i have a workable solution for the time being, and that's what matters :)

All times are GMT -6. The time now is 02:57 AM.

vBulletin © 2020, Jelsoft Enterprises Ltd
© 2004 - 2020 MMOUI