Quantcast
WoWInterface - View Single Post - Astrolabe bug?
Thread: Astrolabe bug?
View Single Post
11-17-14, 11:43 PM   #2
Phanx
Cat.
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 5,617
Originally Posted by myrroddin View Post
Where in Astrolabe's code is the bug found? Which API, Lua file, line number?
The bug is in TomTom's "AddZWaypoint" method, which is why addons are switching to its "AddMFWaypoint" method instead. The "Z" stands for zone, while "MF" stands for map and floor. AddZWaypoint takes a continent index and zone index, asks Astrolabe to translate those into a map and floor, and then calls AddMFWaypoint. Based on a quick look in Astrolabe, it looks like the bug is related to Astrolabe not having been updated (completely/properly/maybe at all) for the changes to GetMapContinents and GetMapZones in WoD.

Beyond that, though, I don't know anything, and don't feel any particular inclination to look into it any further. I'm not really sure why you'd use AddZWaypoint anyway... I'd guess all the addons affected were actually using AddWaypoint, which grabs the current continent and map and calls AddZWaypoint internally, so it's really just a lazy way of adding waypoints in the current zone without having to figure out which zone you're in. Not really a big deal to switch, though obviously it is a bug in Astrolabe that should probably get fixed.
__________________
Author/maintainer of Grid, PhanxChat, oUF_Phanx, and many more.
Troubleshoot an addonTurn any code into an addonMore addon resources
Need help with your code? Post all of your actual code! Attach or paste your files.
Please don’t PM me about addon bugs or code questions. Post a comment or forum thread instead!
  Reply With Quote