WoWInterface - View Single Post - Version: 10.0.1_alpha
View Single Post
10-26-14, 06:36 AM   #1
A Theradrim Guardian
Join Date: Oct 2008
Posts: 60
Version: 10.0.1_alpha

I have seen a few things I think are bugs.

I went through the shattrath portal to Orgrimmar and I got a [VFL] id already existnameplatesearch
Not sure if it is a bug but it didn't seem normal.

I am using the defaultui raid frames. Been using these since wotlk and I see a role icon has been added to them. It displays a healing symbol for me even though I am feral kitty spec. This is while I am solo'ing. I have not tested in a group or raid yet. I prefer to use the raid frame while solo.

This is just stuff I seen right off hand, without doing much digging yet.

First edit:
Ok, I went out to Pandaria the jade forest through the Org portal. I then went to the flight master to fly to vale of eternal blossoms, horde one. But no matter what flight path I clicked on it would not register. I first disabled all add-ons except OpenRDX. Still would not let me click, fly, to any location on the map. I disabled OpenRDX and the first flight path I clicked on it worked. So this tells me it's something with OpenRDX but I did not get any error messages.

Second Edit:
This might be my problem with a custom definition on bar id mainbar 1.

I use a custom definition on mainbar1 and mainbar2. But to my knowledge I included the proper commands for mainbar1 to switch over to vehicle, possess etc. Anyways here is the definition.

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:1,stealth] 8; [bonusbar:1] 6;

At this point everything worked as expected. So I continued and added in the parts for possess, and vehicles. The full custom definition below.

[mod:ctrl] 2; [bar:2] 1; [bar:3] 2; [bar:4] 3; [bonusbar:1,stealth] 8; [bonusbar:1] 6; [vehicleui] 11; [possessbar] 11; [overridebar] 13;

I have no idea what overridebar does except I seen it in the defaultui definition so thought I would need it. If these look correct then RDX is not switching the bars over to vehicle. I can get the vehicle bar to show up on a reloadui however. This might be user error but I can't seem to figure it out so......

Edit 3:
Ok, more info on the flight path issue. I was at Splintertree post trying to fly to Orgrimmar. This time I recieved a Lua Error.

[VFL][*] Lua Error: Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:122 attempt to index global 'NxCData' (a nil value)
[VFL[ TakeTaxiNode : get data from RDX FS
[VFL][*] Lua Error: Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:252 attempt to index global 'NxCData' (a nil value)

Stack trace:
Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:112: in function `hsig'
Interface\AddOns\VFL\Core\DispatchTable.lua:119: in function <Interface\AddOns\VFL\Core\DispatchTable.lua:117>

Stack trace:
Interface\AddOns\RDX\MapMgr\Travels\Travel.lua:198: in function `TakeTaxiNode'
[string "*:OnClick"]:1: in function <[string "*:OnClick"]:1>

Last edited by MNKyDeth : 10-26-14 at 07:12 PM.
  Reply With Quote