Quantcast
WoWInterface - View Single Post - "Prefetching is not allowed"
View Single Post
10-17-08, 01:37 PM   #4
Kaomie
A Scalebane Royal Guard
 
Kaomie's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2007
Posts: 438
Squid does not do (by default) any prefetching on its own. FireFox does, especially on a Google search result page which always adds rel="prefetch" on the first link returned (which IS really annoying for privacy, your browser will always visit the first page without you ever clicking on any link).

Anyway that does narrow a bit where the issue might be and I will have a closer look at the requests. You probably trigger on the X-moz: prefetch HTTP header, and the error returned is either filtered or misunderstood by Squid (must be HTTP 1.1 or something similar).

Keep you posted.

EDIT: you only return a HTTP/1.0 403 Forbidden (text/html) so this is the normal behavior, Squid will only cache the error page.

Quickest fix is to disable prefetching in FF altoghether, which is probably better anyway:
http://developer.mozilla.org/en/Link...prefetching.3f

And I will not explain the long fix because this is obviously not what we want
__________________
Kaomie
"WE LOTS OF PEOPLE FROM STRONG SERVER GUILDS" - Trade Channel

Last edited by Kaomie : 10-17-08 at 04:04 PM.
  Reply With Quote