Quantcast WoWInterface - View Single Post - Extract "wow-update-12759.mpq"... meh!
View Single Post
08-20-10, 05:14 AM   #52
Borlox
A Deviate Faerie Dragon
 
Borlox's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2007
Posts: 13
Edit: Found the error, the right base files are in enUS\patch-enUS.mpq, not in locale-enUS.mpq

Originally Posted by Adys View Post
I'm looking into it. If it's just an error, you can pass validate=False to apply()
I extracted the files and tried the python script with validate=False, but that gives me another error message:
Code:
>python patch.py data\locale-enUS\Interface\FrameXML\ActionButton.lua Data\update-12694\Interface\FrameXML\ActionButton.lua Data\patched-12694\Interface\FrameXML\ActionButton.lua

Traceback (most recent call last):
  File "patch.py", line 186, in <module>
    r = m.apply(old.read(), validate=False)
  File "patch.py", line 153, in apply
    nb, ob = ord(new[cursor + i]), ord(old[oldCursor + i])
IndexError: string index out of range
I couldn't get any file in FrameXML patched...

"MpqEditor.exe enUs\locale-enUS.mpq wow-update-12694.mpq" opens the file without any error message, but it's empty.
The same happens when both update mpqs are used.

Thanks for all the work you've done! I'm really looking forward to a working version

Last edited by Borlox : 08-20-10 at 05:29 AM.