Quantcast
WoWInterface - View Single Post - Lagging
Thread: Lagging
View Single Post
04-11-11, 08:34 PM   #4
jeffy162
A Pyroguard Emberseer
 
jeffy162's Avatar
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 2,360
Actually, getting a quest completion from the servers only seems to take a couple of seconds, and I can't even tell it's happening when I am playing.

Your installation of Carbonite is low memory. Well, compared to mine, anyway. It's not too unusual for me to see Carbonite taking up anywhere from 10 to 15 MB while I play. I've gotten to the point where I just don't even bother looking anymore.

Auctioneer scans always put a big hurt on memory usage, but after its done scanning and then processing the scan, things go pretty much back to normal.

You can get your completed quests from the server anytime (if you are using the Carbonite Quest Log) by clicking the "History" tab along the bottom of the log, and right clicking on the history page and choosing "Get Completed From Server" in the pop up menu.

I've seen posts that insist that memory usage doesn't mean anything, so long as you have plenty installed in your computer. It is definitely not a good way to judge how good, or bad, and addon is. Addon CPU cycles mean more than addon memory usage. You can have an addon that uses very little memory, but if it is written (coded) poorly, that addons CPU usage might be through the roof causing all sorts of other problems.

I play on a two year old laptop with Window's Vista 64bit, crappy Microsoft Integrated Graphics and 4 GIGS of RAM. I also use something around 320 addons. Not the least of which are Carbonite and the Auctioneer Suite. I guess that's not too bad for 35 characters of all different classes and types. I don't really have a problem with RAM. My problem is the crappy integrated graphics. I can barely get 10FPS in Orgrimmar if it's busy. I don't even want to go near Dalaran. Last time I was there I was getting 7FPS just walking around.