Quantcast
WoWInterface - View Single Post - 'My' ClassPower element seems to crash with '/fstack'
View Single Post
10-10-18, 12:26 AM   #1
Lyak
A Cyclonian
Join Date: Jul 2018
Posts: 46
'My' ClassPower element seems to crash with '/fstack'

Hi all,

I've not been touching my Class Power element and even '/fstack' for ages.

Just today I've accidentally pressed the hotkey for '/fstack' command and it gave me the following error.

Code:
2x invalid key to 'next'
[C]: in function `SetFrameStack'
...eBlizzard_DebugTools\Blizzard_DebugTools-1.0.lua:673: in function `FrameStackTooltip_Toggle'
FrameXML\ChatFrame.lua:2356: in function `?'
FrameXML\ChatFrame.lua:4734: in function `ChatEdit_ParseText'
FrameXML\ChatFrame.lua:4396: in function `ChatEdit_SendText'
FrameXML\ChatFrame.lua:2884: in function <FrameXML\ChatFrame.lua:2877>
[C]: in function `UseAction'
FrameXML\SecureTemplates.lua:345: in function `handler'
FrameXML\SecureTemplates.lua:623: in function `SecureActionButton_OnClick'
FrameXML\MultiActionBars.lua:24: in function `MultiActionButtonUp'
[string "MULTIACTIONBAR3BUTTON5"]:4: in function <[string "MULTIACTIONBAR3BUTTON5"]:1>

Locals:
(*temporary) = FrameStackTooltip {
 0 = <userdata>
 showRegions = true
 TopOverlay = <unnamed> {
 }
 showHidden = false
 default = 1
 BottomOverlay = <unnamed> {
 }
 showAnchors = true
 nextUpdate = 0
 commandKeys = <table> {
 }
}
(*temporary) = false
(*temporary) = true
(*temporary) = <unnamed> {
 0 = <userdata>
}
(*temporary) = <unnamed> {
 1 = <unnamed> {
 }
 2 = <unnamed> {
 }
 3 = <unnamed> {
 }
 4 = <unnamed> {
 }
 5 = <unnamed> {
 }
 6 = <unnamed> {
 }
 7 = <unnamed> {
 }
 8 = <unnamed> {
 }
 9 = <unnamed> {
 }
 10 = <unnamed> {
 }
 0 = <userdata>
 ClassPowerEnable = <function> defined @!MyEngine\lib\oUF\elements\classpower.lua:234
 ForceUpdate = <function> defined @!MyEngine\lib\oUF\elements\classpower.lua:229
 ClassPowerDisable = <function> defined @!MyEngine\lib\oUF\elements\classpower.lua:247
 isEnabled = true
 __max = 5
 __owner = oUF_CoG {
 }
}
(*temporary) = "5"
So, I've been debugging quite a while and found that it is causing because of my Class Power element code.

Lua Code:
  1. -- Class Power
  2. local classPower = CreateFrame("Frame", nil, UIParent);
  3. classPower:SetWidth(256);
  4. classPower:SetHeight(36);
  5. classPower:SetPoint("CENTER");
  6.  
  7. for i = 1, 10 do
  8.     local bar = CreateFrame("StatusBar", nil, classPower);
  9.     bar:SetSize(36, 36);
  10.  
  11.     if i == 1 then
  12.         bar:SetPoint("LEFT", classPower, "LEFT");
  13.     else
  14.         bar:SetPoint("LEFT", classPower[i - 1], "RIGHT", 3, 0);
  15.     end
  16.  
  17.     classPower[i] = bar;
  18. end
  19.  
  20. self.ClassPower = classPower;

I have also tested with example code provided on class power and it did not cry for such error

Could anyone please explain me why and how this error is occurring?

Thank you!

-- Edit #1

Basically this occurs when at least ONE class power bar (one combo point) is visible.

Last edited by Lyak : 10-10-18 at 06:31 AM.
  Reply With Quote