WoWInterface - View Single Post - Need some clarification regarding "C_xxxxxx" functions
View Single Post
05-12-18, 02:03 AM   #2
Non-Canadian Luzer!
VincentSDSH's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2006
Posts: 350
They aren't different from the normal APIs. The naming convention is likely for internal housekeeping and organization, differentiating them from Lua functions from their Addons, such as this line from addons\Blizzard_MapCanvas.lua, in :RefreshDetailLayers()
Lua Code:
  1. for layerIndex = 1, C_MapCanvas.GetNumDetailLayers(self.mapID) do
If you called that MapCanvas.GetNumDetailLayers, then there'd be some question as to whether it was a Lua function or a C function, which can be a huge debugging headache for a developer (I speak from experience).
AddonsExecutive Assistant User Configurable To-Do ListLegible Mail Choose the Font for Your Mail
  Reply With Quote