Quantcast
"No player named '[Player Name]' is currently playing." - WoWInterface
 
Thread Tools Display Modes
12-26-14, 04:34 AM   #1
Cogspinner
A Murloc Raider
 
Cogspinner's Avatar
Join Date: Dec 2014
Posts: 5
"No player named '[Player Name]' is currently playing."

Hello, reporting a bug that I have found in the Carbonite Social. I tracked it to when people that I add to friends (Or Carbinite adding them to pals, it seems.) goes offline. I receive a message every 10 seconds stating (Player name masked at the respect of the player I tested it with):
[01:50:33]No player named '[Masked]' is currently playing.
[01:50:43]No player named '[Masked]' is currently playing.
[01:50:53]No player named '[Masked]' is currently playing.
[01:51:03]No player named '[Masked]' is currently playing.
The only way to stop the spam from it is a /reload or delete the pal and friend then readding them. The first case happened with a friend who changed their character name so I had figured that it was the issue there. However, I have since had this happen with a character that has never had a name change and one I know was a pal and not a friend (I never readded this person to friends since the last time I played a couple years ago and have not spoken to them since coming back.). I do not have any other addons that interact with the friends list that I am aware of (Verbose list, Options and modules included);
Code:
!BugGrabber
Align (Typically disabled, only used for UI setup and configuration)
BagBrother
Bagnon
Bagnon_Config
Bagnon_GuildBank
Bagnon_VoidStorage
Bartender4
Carbonite.Info
Carbonite.Items
Carbonite.Notes
Carbonite.Notes.Sample
Carbonite.Quests
Carbonite.Social
Carbonite.Transfer: disabled
Carbonite.Warehouse
Carbonite.Weekly
Carbonite: enabled
CarboniteItems
CarboniteNodes
CarboniteTransfer
Chatter
ElkBuffBars
ErrorFilter
GatherMate2
GatherSageCT
IceHUD
IceHUD_Options
MasterPlan
MogIt
MogIt_Accessories
MogIt_Armorkinis
MogIt_Armory
MogIt_Armory_Cloth
MogIt_Armory_Leather
MogIt_Armory_Mail
MogIt_Armory_Plate
MogIt_Boutique
MogIt_Cloth
MogIt_Highlighter
MogIt_Leather
MogIt_Mail
MogIt_OneHanded
MogIt_Other
MogIt_Plate
MogIt_Ranged
MogIt_Roleplay
MogIt_Sets
MogIt_SetTransmog
MogIt_TwoHanded
MogIt_Wardrobe
MogIt_WowHead
MyRolePlay
NoDuel
OmniCC
OmniCC_Config
OPie
Quartz
Recount
SexyMap
SharedMediaAdditionalFonts
SimpleCalc
tekticles
TidyPlates
TidyPlates_Graphite
TidyPlates_Grey
TidyPlates_Neon
TidyPlates_Quate
TidyPlatesHub
TidyPlatesWidgets
TipTac
TipTacItemRef
TipTacOptions
TipTacTalents
xCT+
XLoot
XLoot_Frame
XLoot_Group
XLoot_Master
XLoot_Monitor
ZPerl
ZPerl_ArcaneBar
ZPerl_CustomHighlight
ZPerl_Options
ZPerl_Party
ZPerl_PartyPet
ZPerl_Player
ZPerl_PlayerBuffs
ZPerl_PlayerPet
ZPerl_RaidAdmin
ZPerl_RaidFrames
ZPerl_RaidHelper
ZPerl_RaidMonitor
ZPerl_RaidPets: disabled
ZPerl_Target
ZPerl_TargetTarget
 
12-26-14, 05:10 AM   #2
gOOvER
A Theradrim Guardian
 
gOOvER's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2008
Posts: 62
I have the same messages, but also without installed Carbonite. I think, thats a Blizz Bug.. An other Guildmate have the same Problem
 
12-26-14, 05:22 AM   #3
ircdirk
A Molten Giant
 
ircdirk's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 797
Try removing Carbonite.Social.lua from WTF folder i might help with this.
 
12-26-14, 08:43 AM   #4
Cogspinner
A Murloc Raider
 
Cogspinner's Avatar
Join Date: Dec 2014
Posts: 5
Originally Posted by gOOvER View Post
I have the same messages, but also without installed Carbonite. I think, thats a Blizz Bug.. An other Guildmate have the same Problem
Strange though that I get it with a person that isn't even added on any Blizzard friend list (Not the one I tested it with tonight.). I get it on fresh characters long after I stopped talking to them and had since deleted the chars friended to them (Logging in made them Pals on my Social). Moreso, I started getting this right after I was testing the Github Carbonite beta before release but not before. I'll try forcing it tomorrow when the person I tested with and see what I get.

Originally Posted by ircdirk View Post
Try removing Carbonite.Social.lua from WTF folder i might help with this.
I'll try this as well, when I can test it tomorrow.
 
12-27-14, 07:28 AM   #5
Cogspinner
A Murloc Raider
 
Cogspinner's Avatar
Join Date: Dec 2014
Posts: 5
Tested it with the same conditions. Added friend to pals and friends, full Carbonite running:
[05:12:43]No player named '[Masked]' is currently playing.
[05:12:49]No player named '[Masked]' is currently playing.
[05:12:59]No player named '[Masked]' is currently playing.
[05:13:09]No player named '[Masked]' is currently playing.
Disabled Carb without changing anything else... No spam at all.

Closed WoW completely and deleted the file pointed out to me. Result being
[05:25:12]No player named '[Masked]' is currently playing.
[05:25:18]No player named '[Masked]' is currently playing.
[05:25:24]No player named '[Masked]' is currently playing.
[05:25:30]No player named '[Masked]' is currently playing.
[05:25:36]No player named '[Masked]' is currently playing.
I deleted all Carbonite related files (Through a search of the Blizzard folder, "*Carbonite*") before and after I attempted the GitHUB beta. For now, I will simply disable Social, not a problem really. It will be looked at when it does, I understand the author is a very busy person and I am just glad to have Carbonite back in action.
 
12-30-14, 08:59 AM   #6
Kaboca
A Murloc Raider
 
Kaboca's Avatar
Join Date: May 2013
Posts: 4
Carbonite registered for the FRIENDLIST_UPDATE event, but recently not always occurs when somebody logout, so as a workarround try to run ShowFriend() it might help.
Code:
/run ShowFriends();
 
12-31-14, 03:44 PM   #7
stones
A Black Drake
Join Date: Jan 2013
Posts: 85
something strange

Ever since I installed Carbonite 6.0.3 iv seen in my chat window when someone logs off see picture
Click image for larger version

Name:	WoWScrnShot_123114_162018.jpg
Views:	744
Size:	494.8 KB
ID:	8406
 
01-01-15, 01:46 AM   #8
pyrephoenix
A Kobold Labourer
Join Date: Mar 2010
Posts: 1
I've been having this happen for months; since at least the beginning of 6.0 if not back to 5.8. At the time I didn't have Carbonite installed as I had too many other addons that were incompatible with it whilst in limbo. I've also seen reports that it could be potentially related to Altoholic/DataStore somehow.

Not saying there's nothing in Carbonite causing it, just that it may not be the only culprit--it may get fixed here and not elsewhere.
 
01-01-15, 03:31 AM   #9
samyonair
A Frostmaul Preserver
 
samyonair's Avatar
Join Date: May 2009
Posts: 257
It's a Problem of cross-realm future (BlizzBug), I had this also without any addons, it is only bad that the failure comes more often with addons loaded.

Greetings Samyonair
 
01-03-15, 09:05 AM   #10
Jynyvieve
A Fallenroot Satyr
Join Date: Sep 2012
Posts: 20
I wanted to add in my voice here too. I get this non stop with social enabled. I run only carbonite, no other addons. Previous to WoD I would get a "hiccup" here and there where it would tell me twice sometimes three times that player named ... not found or not currently playing. Since WoD I have not gotten that notification more than the one time when the person logs off. Then I installed Carb from Curse and now I get it nonstop.
 
01-03-15, 09:48 AM   #11
gOOvER
A Theradrim Guardian
 
gOOvER's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2008
Posts: 62
But this have nothing to do with Carbonite. Doesn't matter if i enabled or disabled Social. I got the same Numbers of Messages

So report this to Blizzard. Thats the easiest way
 
01-09-15, 02:49 PM   #12
stones
A Black Drake
Join Date: Jan 2013
Posts: 85
Yesterday I put a bug report in at Blizz and they said its a add on the is causing this message. They said recount with (sync ) that is causing the No player message, So i disabled all my add on's and reactivate them one at a time till i find the one that is causing this message. I do not use recount.

U have just started doing this will post my resalts
 
01-09-15, 02:56 PM   #13
ircdirk
A Molten Giant
 
ircdirk's Avatar
AddOn Author - Click to view addons
Join Date: Nov 2014
Posts: 797
GitHub version has fix for this, ofcourse only for our addon
__________________
Carbonite and Carbonite Classic Developer
 
01-12-15, 01:18 PM   #14
sumoldguy
A Deviate Faerie Dragon
AddOn Author - Click to view addons
Join Date: Jan 2015
Posts: 16
Originally Posted by ircdirk View Post
GitHub version has fix for this, ofcourse only for our addon

Found an error with the new fix:
Code:
Carbonite GetPos Err:975: Carbonite\NxMap.lua:9129: in function `GetWorldPos'
Carbonite.Quests\NxQuest.lua:10272: in function `GetClosestObjectivePos'
Carbonite.Quests\NxQuest.lua:10211: in function `CalcDistances'
Carbonite.Quests\NxQuest.lua:8583: in function `func'
...\AddOns\Carbonite\Libs\AceTimer-3.0\AceTimer-3.0.lua:55: in function <...\AddOns\Carbonite\Libs\AceTimer-3.0\AceTimer-3.0.lua:48>
 

WoWInterface » Featured Projects » Carbonite » Carbonite: Social Module » "No player named '[Player Name]' is currently playing."

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off