Quantcast Tooltip is constantly reseting the backdrop - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
07-25-18, 11:03 AM   #1
zork
A Pyroguard Emberseer
 
zork's Avatar
AddOn Author - Click to view addons
Join Date: Jul 2008
Posts: 1,739
Tooltip is constantly reseting the backdrop

I am trying to style the GameTooltip and am providing my own backdrop. On top I set my own backdrop color and backdrop border color. For items I am recoloring the border by item rarity.

When I am hovering over any item (like in the character window) that backdrop will be visible for a split second but then the backdrop changes to the default one including all color settings.

Has anyone worked with tooltips lately and has a tip on how to handle that?

Btw sometimes I am getting blueish tinted tooltip backgrounds. It mostly happens when hovering over objects like a portal. When you hover over a unit thereafter the blueish tint stays since I am only reseting the backdrop OnShow.

Any hints would be appreciated.
__________________
| Simple is beautiful.
| WoWI AddOns | GitHub | Zork (WoW) | TDMOG

"I wonder what the non-pathetic people are doing tonight?" - Rajesh Koothrappali (The Big Bang Theory)
  Reply With Quote
 

WoWInterface » Developer Discussions » General Authoring Discussion » Tooltip is constantly reseting the backdrop

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off