Quantcast macro button issue - WoWInterface
Thread Tools Display Modes
10-18-14, 06:41 PM   #1
Drunlol
A Kobold Labourer
Join Date: Oct 2014
Posts: 1
macro button issue

Hi there !

So i'm bumping here cause i noticed something wrong/not working.
I play a warrior and often macro spells like this : /use [mod,@focus][@mouseover,exists][]Spell

Using Ion, for ANY spell i macro'ed like this, everything is working fine, meaning the button turns red if my target is out of range, and if i'm pressing a mod key ( as shift ), trying to use the spell on my focus, the button turns red if the focus is out of range.And obviously with the aura Watch option working the same.
i use omnicc for cooldowns.

Well there is a SINGLE ONE exception : Stormbolt

I just CAN'T get any range display on any button with a stormbolt macro.

BUT if i go to blizzard spellbook, pick up the spell and place it in my Ion bar, THERE i can have the stormbolt range showing properly.

After i did that, i just right clicked the button in edit mode and this is what i could read :

#autowrite
/cast coup traumatisant()

And there it is ! i'm french, and in french stormbolt is " eclair de tempÍte", when "coup traumatisant" is an old version of the spell, now disapeared.
The weird thing is that the button actually casts stormbolt correctly.
But no cooldown and no aura are shown on the button.... only range.

IN the same time, if i open the blizzard macro tool, star a new one, then shift click stormbolt in blizzard spellbook to "autowrite" his name in my macro it wil write : /lancer eclair de tempÍte
which means : /cast stormbolt.

So i think some where in Ion there's a wrong spell id or name ( in french at least ) for Stormbolt.
"Coup traumatisant" should be removed, and replaced by "Eclair de tempÍte".

I would really really appreciate if i was told where to edit which file in order to see the stormbolt spell working properly.

Well... i'm not sure about my theory lol, but maybe you guys can help...

Thank you !

And... HUGES GG's : Since Trinity button your work is just awesome.
  Reply With Quote

WoWInterface » Featured Projects » Ion Engines, Engage! » macro button issue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off