Quantcast
Keep getting a LUA error with my custom rotation WA - WoWInterface
 
Thread Tools Display Modes
10-28-16, 10:07 AM   #1
MithosX
A Kobold Labourer
Join Date: Oct 2016
Posts: 1
Keep getting a LUA error with my custom rotation WA

Hi everyone,

I am desperate need of your help. I've fully updated my WA that use Alayas Stoneheart procs, massacre procs, and lastly Odyn's Fury. I've also tried to simplifying the code by deleting stuff I don't need. However I keep getting stuck on this weird LUA error. It happens after I kill a few mob and target a dead mob. After that the entire WA stops working and I get spawned with the same LUA error.

Which is this:

However the LUA error seems to be totally gone if I disable (as in load: never in WA) icon 2 (which is the "use next" icon. Though I don't know what to change there to fix it since the LUA error isn't giving me any info on where it is in the WA.

This is my current WA: http://pastebin.com/3PH7gx6d (with icon 2 enabled).

Your help will be greatly appreciated!
  Reply With Quote
10-29-16, 03:04 PM   #2
Phanx
Cat.
 
Phanx's Avatar
AddOn Author - Click to view addons
Join Date: Mar 2006
Posts: 5,617
The error is telling you exactly what's wrong. The values are being passed to the GetSpellCooldown function do not identify a valid spell to check.

If you're calling this function yourself in a Lua code snippet, check for typos or other problems with the values you're passing it, and/or post the actual snippet.

If you're not calling it yourself, check the names or IDs you've entered for any spells anywhere, and make sure they match exactly what's shown in your spellbook.
__________________
Retired author of too many addons.
Message me if you're interested in taking over one of my addons.
Donít message me about addon bugs or programming questions.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Keep getting a LUA error with my custom rotation WA

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off