Quantcast
Popups - various issues - WoWInterface
Thread Tools Display Modes
11-16-14, 03:46 AM   #1
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Popups - various issues

I'm running into several issues with popups for achievements, loot roll wins, and alerts for garrison mission completion.

As far as the achievement popups and loot roll wins the issue I'm running into is that they slowly seem to be drifting down off the screen. When I started my play session they appeared at the top center. By the time I stopped they were appearing at bottom center, even edging off the screen completely. Even though I hadn't changed settings. It almost seems like they are appearing at the bottom of where the previous one was.

Second, for the garrison popups, sometimes they have text, other times they don't.

I'm not sure what is causing any of these issue and they are are relatively minor things but they can detract from what is otherwise an amazing looking UI.

I should also add that there isn't any errors to speak of and I'm pretty sure a /reloadui fixes the first issue for a while but the second one seems completely random as far as I can tell.

Last edited by even13 : 11-16-14 at 03:50 AM.
  Reply With Quote
11-17-14, 04:41 AM   #2
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Seems it has something to do with Aurora. That's causing a lot of UI issues with anything but the main hud and action bars.

Such as tooltips on the map to appear underneath of it and other things.
  Reply With Quote
11-17-14, 06:14 AM   #3
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Further testing seems to indicate there are some issues with Aurora. I did a completely clean install with no other addons and it was causing the tooltips on the map to disappear.

Disabling aurora fixed that particular issue. I'm not sure if I should be reporting this here or on the aurora addon page.

Edit: Tested Aurora by itself and it didn't seem to have any issues. So that narrows it down to the !Aurora_RealUI that is causing my issues.

Edit 2: Twice confirmed. Did another clean install and this time only disabled !Aurora_RealUI and no issues. Seems like it's getting the strata wrong or something because I can see text behind the map if the thing I'm point at is near they edge of it.

Edit 3: Nailed down where the issue is a little more. When I have the map in what I'm going to call big mode, the issue shows it self. But when I have it in small mode (toggle button next to the close button) it's fine. If I knew lua I could probably fix it myself, but I don't, so yeah...

Edit 4: I still don't know if that fixes my other pop up issues but we'll see.

Last edited by even13 : 11-17-14 at 06:52 AM.
  Reply With Quote
11-18-14, 05:23 PM   #4
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Loot win notifications still creeping up the screen. No idea what's causing it.

Edit: To add more to this, it seems to happen when multiple popups show up at the same time. When a new pop up occurs it happens ontop of the old one.

It doesn't have to just a loot roll pop up, it can be garrison ones as well, or any other kind of alert.

Last edited by even13 : 11-18-14 at 08:29 PM.
  Reply With Quote
11-19-14, 07:14 PM   #5
Gethe
RealUI Developer
 
Gethe's Avatar
Premium Member
Featured
Join Date: Sep 2008
Posts: 930
i'm not seeing the positional issue with the alert frames. This has come up before as a conflict with an addon not included with RealUI.
__________________
Knowledge = Power; Be OP

  Reply With Quote
11-20-14, 02:12 AM   #6
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Originally Posted by Gethe View Post
i'm not seeing the positional issue with the alert frames. This has come up before as a conflict with an addon not included with RealUI.
Do you know which one? I'm not using very many extra addons, ones not included in Realui:

Archy
Gathermate2
Handynotes + Draenor Treasures
Quecho
rDamageFont
rCombatText
TomTom
xCT+

Out of those, both Archy and Handynotes were installed after I started seeing the issue pop up (pun intended). So those two can be ruled out.

Last edited by even13 : 11-20-14 at 01:10 PM.
  Reply With Quote
11-20-14, 06:44 PM   #7
Gethe
RealUI Developer
 
Gethe's Avatar
Premium Member
Featured
Join Date: Sep 2008
Posts: 930
I would just disable all of them, then re-enable them one at a time until you see the issue again.
__________________
Knowledge = Power; Be OP

  Reply With Quote
12-03-14, 08:55 PM   #8
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Reporting back that I've disabled all extra addons and played extensively with the default package for quite a while and the issue is still occuring.

It has something to do with the position of popups/toasts not resetting when more than one is on the screen at the same time.
  Reply With Quote
12-03-14, 09:00 PM   #9
Aranan
A Murloc Raider
 
Aranan's Avatar
Join Date: Feb 2007
Posts: 9
I just want to add to this that I have disabled all non RealUI addons and I have the same issue. Loot win rolls, item upgrades from quests, and follower mission popups all steadily creep off the screen if I haven't done a /reloadui recently.
  Reply With Quote
12-04-14, 01:12 AM   #10
groin
A Cyclonian
AddOn Compiler - Click to view compilations
Join Date: Nov 2008
Posts: 45
Have the same issue with loot win notification.
I don't use other addons then realui

Last edited by groin : 12-04-14 at 01:18 AM.
  Reply With Quote
12-07-14, 06:38 PM   #11
even13
A Deviate Faerie Dragon
Join Date: Feb 2008
Posts: 12
Glad I'm not the only one having the issue with the popups. I thought I was doing something wrong for a while.
  Reply With Quote
12-14-14, 02:06 AM   #12
Triksterism
A Wyrmkin Dreamwalker
 
Triksterism's Avatar
AddOn Author - Click to view addons
Join Date: May 2009
Posts: 52
Also glad it's not just me
__________________
  Reply With Quote

WoWInterface » Featured Projects » RealUI » Popups - various issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off