Quantcast
Quest Lag - WoWInterface
 
 
Thread Tools Display Modes
04-10-13, 04:39 PM   #1
Mardread
A Deviate Faerie Dragon
Join Date: Jun 2008
Posts: 19
Quest Lag

I am doing the dailies on isle of thunder and my carbonite is eating memory causing lag spikes in fps. At one point, the carbonite.quests module was using 23 MB of memory. It is extremely noticeable. I am running a 680GTX and have no issues running WoW at all, so there seems to be an issue here and it appeared with the latest update, beta 9 and patch 1.

Other than that, it is working very well. Thank you for all your hard work.
 
04-10-13, 06:31 PM   #2
anteract
Premium Member
Premium Member
Join Date: Dec 2006
Posts: 38
Alpha 9 R 1 Memory Leak

Not gonna get all dramatic like ^^ but there is a memory leak.

Doing nothing, staring off into space, my memory used by Carbonite is slowly increasing. 11.12Mb to 11.81Mb in just the time it took to type this out.
 
04-10-13, 06:38 PM   #3
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
it fixes itself when garbage collection happens, it's from blizzards strsplit function... trying to find an alternative to it
 
04-10-13, 06:46 PM   #4
Mardread
A Deviate Faerie Dragon
Join Date: Jun 2008
Posts: 19
Originally Posted by Rythal View Post
it fixes itself when garbage collection happens, it's from blizzards strsplit function... trying to find an alternative to it
I know it corrects itself and I can dump it manually. Its the lag that is the problem. Thanks again Rythal, the new module works very well on top of that issue and I have had no problems at all following quests in all the areas.
 
04-11-13, 07:29 AM   #5
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
I may have it figured out... was only able to test on my test account (was skipping raid to work on it :P), but Nx.Quest never went above 7.5, and Carbonie never went above 5M of usage

I replaced blizzards strsplit with my own that caches the return in a weak table
 
04-11-13, 03:23 PM   #6
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
update on it... seems to be working in some places, and not in others... my memory usage is under control everywhere except shrine / vale, where it skyrockets rapidly ... noticed some small bugs I need to get at, but memory / lag is still priority.
 
 

WoWInterface » Featured Projects » Carbonite » Carbonite Archive » Quest Lag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off