Quantcast WorldFrame issues in Classic - WoWInterface
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
09-11-19, 12:22 PM   #1
kernighan
A Cyclonian
AddOn Author - Click to view addons
Join Date: Mar 2008
Posts: 45
WorldFrame issues in Classic

For one of my addons, users are reporting they see the following (although I never see this reported):

172x Couldn't find frame parent: WorldMapDetailFrame
I'm not really sure what to do about this one at all.

AddOn RecipeRadarClassic attempted to call a protected function (CompactRaidFrameContainer:Hide()) during combat lockdown
This is maybe related to what's mentioned here and seems to imply I need to stop using SetPoint and use SetOwner instead. But the documentation for SetOwner doesn't have setting analogous to what I'm doing in my addon, so I'm not sure what to do there.

For example, I have:

RecipeRadarAvailabilityTooltip:SetPoint(
"TOPLEFT", frame:GetName(), "TOPRIGHT", 35, 0)
which doesn't match any of those options.

I also get reports from players that they're getting these errors, which I've also never seen and am not sure what to do about:

Frame RecipeRadarAvailabilityTooltip: Unknown script element OnTooltipSetDefaultAnchor
Frame RecipeRadarAvailabilityTooltip: Unknown script element OnTooltipAddMoney
Frame RecipeRadarAvailabilityTooltip: Unknown script element OnTooltipCleared
Help appreciated!
  Reply With Quote
 

WoWInterface » Classic - AddOns, Compliations, Macros » Classic - AddOn Help/Support » WorldFrame issues in Classic

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off