Quantcast
"Prefetching is not allowed" - WoWInterface
Thread Tools Display Modes
10-17-08, 08:25 AM   #1
Kaomie
A Scalebane Royal Guard
 
Kaomie's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2007
Posts: 438
"Prefetching is not allowed"

Hiya,

Sometimes I get this blank page with only the following message:
Code:
Prefetching is not allowed due to the various privacy issues that arise.
This usually happens when googling for an addon and clicking on the link that goes directly to an addon page. I am suspecting this is due to some combination of FireFox+Google+Squid, but I have not confirmed exactly what mechanism triggers it.

If you tell me what you do not want us to do, I can probably tweak my FF or Squid configuration to adapt accordingly.

Thanks,
__________________
Kaomie
"WE LOTS OF PEOPLE FROM STRONG SERVER GUILDS" - Trade Channel
  Reply With Quote
10-17-08, 09:56 AM   #2
Shirik
Blasphemer!
Premium Member
WoWInterface Super Mod
AddOn Author - Click to view addons
Join Date: Mar 2007
Posts: 818
I've heard of this before, and it's Squid being a bad man.

Prefetching is a pretty simple concept: Let's say you google for something. All those links pop up. While your browser (or in this case, your proxy) is sitting there doing nothing after that page has loaded waiting for you to click a link, it wants to speed things up. So what it does is actually silently follows each of those links to start downloading it ahead of time, in preparation for you to click them. This way, if you do actually click the link, your load time will (appear to) be shorter.

We don't allow this due to various issues.

The problem: When it's blocked, we DO use an HTTP error code. Firefox does prefetching as well (I think IE does also) and detects this error code and knows not to cache that information. Squid, on the other hand, ignores the error code and caches the error page. Thus, if you click the link after it's been prefetched, Squid goes ahead and delivers the (incorrect) error page instead.

I don't actually know the resolution to this unfortunately, I just know that's where the problem lies because it's come up before. Hopefully it's enough information to get you started, though.

Good luck,
-- Shirik
__________________
たしかにひとつのじだいがおわるのお
ぼくはこのめでみたよ
だけどつぎがじぶんおばんだってことわ
しりたくなかったんだ
It's my turn next.

Shakespeare liked regexes too!
/(bb|[^b]{2})/

Last edited by Shirik : 10-17-08 at 09:58 AM.
  Reply With Quote
10-17-08, 10:10 AM   #3
Dolby
PPAP
 
Dolby's Avatar
WoWInterface Admin
Join Date: Feb 2004
Posts: 2,276
The problem was the end users proxy.
  Reply With Quote
10-17-08, 01:37 PM   #4
Kaomie
A Scalebane Royal Guard
 
Kaomie's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2007
Posts: 438
Squid does not do (by default) any prefetching on its own. FireFox does, especially on a Google search result page which always adds rel="prefetch" on the first link returned (which IS really annoying for privacy, your browser will always visit the first page without you ever clicking on any link).

Anyway that does narrow a bit where the issue might be and I will have a closer look at the requests. You probably trigger on the X-moz: prefetch HTTP header, and the error returned is either filtered or misunderstood by Squid (must be HTTP 1.1 or something similar).

Keep you posted.

EDIT: you only return a HTTP/1.0 403 Forbidden (text/html) so this is the normal behavior, Squid will only cache the error page.

Quickest fix is to disable prefetching in FF altoghether, which is probably better anyway:
http://developer.mozilla.org/en/Link...prefetching.3f

And I will not explain the long fix because this is obviously not what we want
__________________
Kaomie
"WE LOTS OF PEOPLE FROM STRONG SERVER GUILDS" - Trade Channel

Last edited by Kaomie : 10-17-08 at 04:04 PM.
  Reply With Quote

WoWInterface » Site Forums » Site help, bugs, suggestions/questions » "Prefetching is not allowed"

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off