Quantcast Installation Requirements - WoWInterface
 
Thread Tools Display Modes
10-01-05, 07:06 PM   #1
Nulkris
A Cobalt Mageweaver
 
Nulkris's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2005
Posts: 214
Exclamation Installation Requirements

Installation Requirements

Links to required files:

Windows Installer 3.1 - required to install the .NET 2 redistributable, that link requires genuine Windows validation.
Microsoft .NET Framework Version 3.5 SP1 Redistributable Package (x86)
Microsoft .NET Framework Version 1.1 Redistributable Package - may be required if Lua interface does not work correctly.

Steps:

1. Install all latest service packs.
2. Install Windows Installer 3.1
3. Install Microsoft .NET 3.5 SP1 Release redistributable
4. Ensure that a copy of World of Warcraft is installed correctly on your system. Use regedit.exe to check HKEY_LOCAL_MACHINE/SOFTWARE/Blizzard Entertainment/World of Warcraft/InstallPath to see if you have a good install. You can change the path in the wowuides program options later, but this reduces the problems.
5. Run WoW UI Designer v1.1.X.msi to install the program.
6. Incase of problems, install the Microsoft .NET Framework Version 1.0 Redistributable Package (plus all service packs) and Microsoft .NET Framework Version 1.1 Redistributable Package.

If you are installing over a previous version, make sure that you either uninstall if you have the option, or delete the *.exe and *.dll files in the directory.
__________________
Nulkris - A80 Rogue - Proudmoore
(Also Drukris, Hamkris on Proudmoore; Hulkris on Jubei'Thos & Khaz Modan)

Last edited by Nulkris : 09-06-08 at 11:28 PM. Reason: Updated information.
  Reply With Quote
10-01-05, 08:33 PM   #2
Cairenn
Credendo Vides
 
Cairenn's Avatar
Premium Member
WoWInterface Admin
Join Date: Mar 2004
Posts: 7,111
Well, installation was a breeze. Now to play!
__________________
“Do what you feel in your heart to be right — for you’ll be criticized anyway.” ~ Eleanor Roosevelt
~~~~~~~~~~~~~~~~~~~
Co-Founder & Admin: MMOUI
FaceBook Profile, Page, Group
Avatar Image by RaffaeleMarinetti
  Reply With Quote
10-02-05, 06:35 PM   #3
neriak_x
An Aku'mai Servant
AddOn Author - Click to view addons
Join Date: Sep 2005
Posts: 32
Hi,

I've tried as hard as I could, but the wowuides.exe doesn't run on my machine. I've installed every requirements, checked the reg, run the Interface Kit and extracted the fonts but I get a non-saying MsgBox: Microsoft has found an error, blabla closing. (I don't know the english one, since my Windows is German).

I'm running WinXP Pro SP2 on an AMD 1600+, 1GB SDRAM, ATI Radeon 9600 256 MB. This is a rather new and clean Windows installation, so now I'm absolutely clueless. The Errorlogs didn't find any Issue regarding your application.

Oh yes, I also installed the Alpha Patch, of course.
__________________
~ N: "All Semicolons must die!" ~R: "Yay!"
Neriak's Portal
  Reply With Quote
10-05-05, 11:28 AM   #4
Spew
A Murloc Raider
Join Date: Oct 2005
Posts: 6
I needed the 1.1 .Net Redist, and after that it installed just fine.
  Reply With Quote
10-30-05, 01:14 PM   #5
Mirium
A Defias Bandit
Join Date: Oct 2005
Posts: 3
Ok, I must have, at some point, installed the WoW custom Interface kit then deleted the files. Now when I try to reinstall it it says it's already installed and refuses to go further. Anyone know how to fix this?
  Reply With Quote
10-31-05, 03:08 AM   #6
Nulkris
A Cobalt Mageweaver
 
Nulkris's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2005
Posts: 214
Post

Sorry, I've been out all day. You need to delete everything in the [wow]/Interface directory except for your Addons directory. Also, if you have installed the test version, then you will need to delete everything in [wow]/wowtest/interface except the addons. Then it should work.
__________________
Nulkris - A80 Rogue - Proudmoore
(Also Drukris, Hamkris on Proudmoore; Hulkris on Jubei'Thos & Khaz Modan)
  Reply With Quote
11-21-05, 04:31 AM   #7
zhuchong530
A Kobold Labourer
Join Date: Nov 2005
Posts: 1
I'm Chinese!
my windows is chinese
It's Windows 2000 Advanced Server
May I use it on my Operation System?
Thank you~
  Reply With Quote
12-07-05, 04:30 PM   #8
mercdev
A Fallenroot Satyr
 
mercdev's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: May 2005
Posts: 22
Originally Posted by zhuchong530
I'm Chinese!
my windows is chinese
It's Windows 2000 Advanced Server
May I use it on my Operation System?
Thank you~
Yes - Be sure to install the Microsoft .NET Framework Version 2.0 Redistributable Package (x86), as well as the Microsoft .NET Framework Version 1.1 Redistributable Package if you haven't already done so.
  Reply With Quote
01-09-06, 03:42 AM   #9
Kaaosa
A Defias Bandit
 
Kaaosa's Avatar
Join Date: Jan 2006
Posts: 2
Alright, I followed the instructions by the letter and when I start up WoW UI Designer I et a bunch of errors, mostly Frame XML errors, and the toolbox is empty. Is there something I've overlooked?

Oh, most of the errors are in the form of:
Inherited frame X not found

where X is several things, including UIPanelButtonTemplate, UICheckButtonTemplate, and UIPanelCloseButton. Ther eare several other frames mentioned in the same type of error.

Last edited by Kaaosa : 01-09-06 at 03:45 AM.
  Reply With Quote
01-09-06, 04:56 AM   #10
Nulkris
A Cobalt Mageweaver
 
Nulkris's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2005
Posts: 214
See http://www.wowinterface.com/forums/s...ead.php?t=2836

(i.e. Uncheck Validate Blizzard files against the Schema)
__________________
Nulkris - A80 Rogue - Proudmoore
(Also Drukris, Hamkris on Proudmoore; Hulkris on Jubei'Thos & Khaz Modan)
  Reply With Quote
01-11-06, 01:50 PM   #11
Climax
A Defias Bandit
Join Date: Jan 2006
Posts: 3
A prob

Hey, thnx for the program but i have a little prob i followed everything how to install but when i started it up i didnt found anything

I made a link to a screenshot of the problem so you can see wat the problem is.

link to screenshot : http://img269.imageshack.us/my.php?image=theprob0vc.png

hope you can help me out
  Reply With Quote

WoWInterface » Developer Discussions » General Authoring Discussion » Installation Requirements

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off