Quantcast Question Regarding PlayerModel Frame - WoWInterface
Thread Tools Display Modes
05-29-09, 09:22 PM   #1
TooDeep
A Defias Bandit
AddOn Author - Click to view addons
Join Date: Apr 2009
Posts: 3
Question Regarding PlayerModel Frame

I am using the 3D PlayerModel frames in my unit frame mod, but I'm having an issue where the camera for the frames revert to a full view body shot instead of the zoomed in face shot that I set it to. This happens after the interface is hidden (via alt-z) or when the world map is brought up and down.

Does anybody know if there is an event attached to the alt-z hide UI keybinding or something along those lines so that I can reset my portraits?
  Reply With Quote
06-09-09, 12:18 PM   #2
Tearstar
A Cyclonian
 
Tearstar's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2009
Posts: 42
Originally Posted by TooDeep View Post
I am using the 3D PlayerModel frames in my unit frame mod, but I'm having an issue where the camera for the frames revert to a full view body shot instead of the zoomed in face shot that I set it to. This happens after the interface is hidden (via alt-z) or when the world map is brought up and down.

Does anybody know if there is an event attached to the alt-z hide UI keybinding or something along those lines so that I can reset my portraits?


Go into the LUA file for the fames and look for onShow and put in something like
Code:
PlayerModel:SetCamera(0);
then anytime the frame is shown it will set the Camera to a full face view
__________________
Author of Mini-Targ

Magelo Profile
My Myspace
My Youtube Channel

My First Video I made for my kids - please comment and/or rate

  Reply With Quote
06-16-09, 04:49 AM   #3
TooDeep
A Defias Bandit
AddOn Author - Click to view addons
Join Date: Apr 2009
Posts: 3
Originally Posted by Tearstar View Post
Go into the LUA file for the fames and look for onShow and put in something like
Code:
PlayerModel:SetCamera(0);
then anytime the frame is shown it will set the Camera to a full face view
Yea, I do that when the portrait update event fires and when I change targets. The problem is I'm not sure how to set it to do that when the UI gets hidden/shown with alt-z. I don't want to constantly be setting the camera because it will reset the animation as well and would look choppy in the frame.
  Reply With Quote
06-16-09, 05:05 AM   #4
Slakah
A Molten Giant
 
Slakah's Avatar
AddOn Author - Click to view addons
Join Date: Aug 2007
Posts: 863
Couldn't you just do

Code:
PlayerModel:SetScript("OnShow", function(self) self:SetCamera(0) end)
  Reply With Quote
06-17-09, 02:33 AM   #5
TooDeep
A Defias Bandit
AddOn Author - Click to view addons
Join Date: Apr 2009
Posts: 3
Originally Posted by Slakah View Post
Couldn't you just do

Code:
PlayerModel:SetScript("OnShow", function(self) self:SetCamera(0) end)
That worked! Thanks
  Reply With Quote

WoWInterface » Developer Discussions » General Authoring Discussion » Question Regarding PlayerModel Frame

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off