Quantcast
Quest Lag - WoWInterface
 
Thread Tools Display Modes
04-10-13, 04:39 PM   #1
Mardread
A Deviate Faerie Dragon
Join Date: Jun 2008
Posts: 19
Quest Lag

I am doing the dailies on isle of thunder and my carbonite is eating memory causing lag spikes in fps. At one point, the carbonite.quests module was using 23 MB of memory. It is extremely noticeable. I am running a 680GTX and have no issues running WoW at all, so there seems to be an issue here and it appeared with the latest update, beta 9 and patch 1.

Other than that, it is working very well. Thank you for all your hard work.
 
04-10-13, 06:31 PM   #2
anteract
Premium Member
Premium Member
Join Date: Dec 2006
Posts: 38
Alpha 9 R 1 Memory Leak

Not gonna get all dramatic like ^^ but there is a memory leak.

Doing nothing, staring off into space, my memory used by Carbonite is slowly increasing. 11.12Mb to 11.81Mb in just the time it took to type this out.
 
04-10-13, 06:38 PM   #3
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
it fixes itself when garbage collection happens, it's from blizzards strsplit function... trying to find an alternative to it
 
04-10-13, 06:46 PM   #4
Mardread
A Deviate Faerie Dragon
Join Date: Jun 2008
Posts: 19
Originally Posted by Rythal View Post
it fixes itself when garbage collection happens, it's from blizzards strsplit function... trying to find an alternative to it
I know it corrects itself and I can dump it manually. Its the lag that is the problem. Thanks again Rythal, the new module works very well on top of that issue and I have had no problems at all following quests in all the areas.
 
04-11-13, 07:29 AM   #5
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
I may have it figured out... was only able to test on my test account (was skipping raid to work on it :P), but Nx.Quest never went above 7.5, and Carbonie never went above 5M of usage

I replaced blizzards strsplit with my own that caches the return in a weak table
 
04-11-13, 03:23 PM   #6
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
update on it... seems to be working in some places, and not in others... my memory usage is under control everywhere except shrine / vale, where it skyrockets rapidly ... noticed some small bugs I need to get at, but memory / lag is still priority.
 
04-11-13, 05:30 PM   #7
Nimhfree
A Frostmaul Preserver
AddOn Author - Click to view addons
Join Date: Aug 2006
Posts: 264
Rythal, if you figure out what is happening in the Vale, please share that as I have been given reports that Grail acts up in the Vale as well, but all the other zones are fine. I have not yet been able to track it down.
 
04-13-13, 01:52 AM   #8
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
Originally Posted by Nimhfree View Post
Rythal, if you figure out what is happening in the Vale, please share that as I have been given reports that Grail acts up in the Vale as well, but all the other zones are fine. I have not yet been able to track it down.
Not sure if it's the same issue for you, but from what i've found so far, the moment your avatar crosses into the shrine boundries WORLD_MAP_UPDATE starts firing a billion times a second.

I've got it echoing each event fire right now, and anywhere else it's the normal every 8-10 seconds for 1 fire... soon as I cross that invisible line, my chat is flooded with them.
 
04-13-13, 11:12 AM   #9
Dman24
A Murloc Raider
Join Date: Nov 2010
Posts: 8
So i was doing some quests today on an Alt and noticed the random FPS drops and thought it was just because i was in a busy area. Today I'm doing old quest for achievements and noticed it, decided to look into it and started disabling add-ons. Nothing was working so i saw hell let me try Carbonite, disabled it lag went away.

So I started putting parts back on in Carbonite one by one and found the Quests module was causing the FPS lag. So currently running everything on Carbonite except for the quests module currently. Hope to get this fixed soon.

Oh and also is it just me or is the Shrine Of Two Moons causing fps to be single digits at times?

Last edited by Dman24 : 04-13-13 at 11:20 AM.
 
04-13-13, 09:52 PM   #10
LothwenTLU
A Deviate Faerie Dragon
Join Date: Sep 2012
Posts: 16
Same issues with lag and jerkiness as Dman24 - had improved over last time I said something about it, but got bad again - disabled quests module, and it all runs smoothly. This was especially bad in the Isle of Thunder, in the Ihgaluk Crag area, when I had the roach-stomping quest. Every time I'd step on one, it'd freeze up for half a second or so.
 
04-13-13, 10:11 PM   #11
Dman24
A Murloc Raider
Join Date: Nov 2010
Posts: 8
So to answer my own question regarding the lag in the Shrine of Two Moons I was at about 15 FPS which is really low. So i did what i did with the lag in the low level questing zones I disabled the quests module and boom 40 FPS.

So I don't know if its LUA errors (have an add-on that doesn't show them) or what. This is on Ultra Settings with latest graphics drivers and a Nvidia GTX 660 card recently bought on Thursday so fairly new.
 
04-14-13, 06:29 AM   #12
Rythal
Featured Artist
Featured
Join Date: Aug 2012
Posts: 1,458
So... just uploaded R2, let me know how it compares performance wise


Some changes:
Added time since last run checks to quest watch window (updates every 2 seconds at minimum) and zone scanning for blizzard quest info (2 seconds again).

Caching string splits mentioned above

Found and fixed the problem with two moons and seven stars by forcing carbonite to always say your in vale. The memory usage in those 2 places was from Carbonite thinking your in a new zone while in either shrine, and fighting with itself since one AreaID call gave vale's number, and the other gave shrines number so it was constantly jumping between the two every few milliseconds.
 
04-14-13, 12:41 PM   #13
Dman24
A Murloc Raider
Join Date: Nov 2010
Posts: 8
Just testing it out and Shrine of two Moons is back to the normal FPS doing at about 65 FPS with quest module turned on.

And with the quest tracking when you have to kill certain amount there is little to no FPS drop great work man.
 
 

WoWInterface » Featured Projects » Carbonite » Carbonite Archive » Quest Lag

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off