Quantcast
Fontstring written over old value - WoWInterface
Thread Tools Display Modes
05-12-15, 03:36 AM   #1
Yukyuk
A Chromatic Dragonspawn
 
Yukyuk's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2015
Posts: 176
Fontstring written over old value

Ok, got a funny one this time.
When displaying a fontstring the new value is written over the previous one (see the amount field in the picture).
No idea why this is happening.
Allready searched the forums here but didn't find an answer.
Maybe someone can point me in the right derection?



Last edited by Yukyuk : 05-12-15 at 03:36 AM. Reason: Typo
  Reply With Quote
05-12-15, 04:17 AM   #2
Resike
A Pyroguard Emberseer
AddOn Author - Click to view addons
Join Date: Mar 2010
Posts: 1,289
You probably create a new FontString every time you update the values, instead of just update it's text.
  Reply With Quote
05-12-15, 05:22 AM   #3
Dorwido
A Wyrmkin Dreamwalker
AddOn Author - Click to view addons
Join Date: Apr 2006
Posts: 54
Question like that you should at least post the part of the code producing it otherwise its a wild guess, but in this case I am quite sure Resike answer is correct.
__________________
Auction Analytics
http://www.wowauction.org/
  Reply With Quote
05-12-15, 07:32 AM   #4
Yukyuk
A Chromatic Dragonspawn
 
Yukyuk's Avatar
AddOn Author - Click to view addons
Join Date: Apr 2015
Posts: 176
You are both right.
Creating a new font string each time, stupid of me.

Also found the answer myself while out eating pancakes.
And then they say men can't multitask
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » Fontstring written over old value

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off