Quantcast
nUI -- A full feature standalone UI replacement - Page 111 - WoWInterface
 
Thread Tools Display Modes
01-02-09, 10:02 AM   #2201
tintingurl
A Frostmaul Preserver
 
tintingurl's Avatar
Join Date: Jan 2007
Posts: 295
sorry again downloaded the update and played worked well untill i went in a group with one other person fps went to like 12 and under f or some reason.

again i went back the the old one i had for the time being.
__________________
 
01-02-09, 10:17 AM   #2202
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
You were grouped with *one* person and the FPS dropped to 12?

/sigh

The only thing I can suggest is the same thing I always seem to suggest in cases like this... try exiting WoW and renaming your World of Warcraft > WTF folder to World of Warcraft > WTF.saved and then log back in.

There has to be some kind of artifact thing going on here and I didn't see frame rates that low in a 40 man and I spent all night last night in a normal group and never saw frame rates below 40fps on a laptop. So something off is up.

A lot of "strange" behavior these last few days. I wish I had a clue why.

Originally Posted by tintingurl View Post
sorry again downloaded the update and played worked well untill i went in a group with one other person fps went to like 12 and under f or some reason.

again i went back the the old one i had for the time being.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
 
01-02-09, 11:12 AM   #2203
AsheruWolf
Premium Member
 
AsheruWolf's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Jan 2006
Posts: 131
Originally Posted by spiel2001 View Post
Oh gawd... please DO NOT blame that thing on me! ~lol~
Spiel2001 do you have any complaints if someone pops out a user made change for a temp fix to the ugly old bliz frame?
__________________
The end is never really the end, its the start of something new...
 
01-02-09, 11:22 AM   #2204
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Originally Posted by AsheruWolf View Post
Spiel2001 do you have any complaints if someone pops out a user made change for a temp fix to the ugly old bliz frame?
What do you have in mind?

The reason I haven't hidden the frame automatically myself is that there are some quests where you need it because of features nUI doesn't have yet... so if hiding it is what you have in mind, then I would argue against it. But if you have something else in mind, I'm all ears.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
 
01-02-09, 12:46 PM   #2205
AsheruWolf
Premium Member
 
AsheruWolf's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Jan 2006
Posts: 131
I was just thinking of a change to its scale and trying to make it fit into the area where you have what is currently health and group frames.
__________________
The end is never really the end, its the start of something new...
 
01-02-09, 01:09 PM   #2206
Tamsiel
Premium Member
Join Date: Oct 2007
Posts: 11
FPS Drop

First off love your UI! Here's what I've noticed with the newest version; about every five minutes framerate drops from 60+ to around 22+ for about 5 seconds when I play under Windows. When I play under OS-X framerate drops from 50+ to around 14 for the same amount of time. No new addons or anything added, just upgraded from 4.07 to 4.09
 
01-02-09, 01:24 PM   #2207
fred
A Cobalt Mageweaver
Join Date: Mar 2006
Posts: 208
Originally Posted by spiel2001 View Post
Then something else is wrong Fred. It's not this version, I'm sure of it.

I might suggest you try exiting WoW and renaming your World Of Warcraft\WTF to World of Warcraft\WTF.saved and then log back in... see if it plays nice then. I've been playing this version for a good 12 hours not to mention the time I spent testing the version before it and I'm certain it does not have major time issues... in fact, I'm seeing some of the best performance I've seen in nUI in a long time.

We need to sort out what the issue is that caused you a problem. Did it lag out as soon as you logged in or when you were in the middle of doing something?
Something is seriously wrong now.With ANY mods loaded now I get a 'hitch' in gameplay. I deleted my wtf, started over 3x.I originally had an error with a mod called TradeskillProfitMax and Auctioneer.I deleted the offending mod but STILL had the error.Deleted WTF and I started having the 'hitch'....no matter what combination of mods I turn on I still have it. Ran a repair also.....GGRRR!!!!!! I really dread a full re install though.

Something seems tainted.Errors that shouldn't be there after a relog are coming back...even after the mod throwing the errors are removed.I am getting really bummed out over this.I can provide a list of mods I have loaded.Any suggestions would be helpful!! Thanks
 
01-02-09, 01:47 PM   #2208
mscott998
A Chromatic Dragonspawn
Join Date: Aug 2008
Posts: 152
Originally Posted by fred View Post
Something is seriously wrong now.With ANY mods loaded now I get a 'hitch' in gameplay. I deleted my wtf, started over 3x.I originally had an error with a mod called TradeskillProfitMax and Auctioneer.I deleted the offending mod but STILL had the error.Deleted WTF and I started having the 'hitch'....no matter what combination of mods I turn on I still have it. Ran a repair also.....GGRRR!!!!!! I really dread a full re install though.

Something seems tainted.Errors that shouldn't be there after a relog are coming back...even after the mod throwing the errors are removed.I am getting really bummed out over this.I can provide a list of mods I have loaded.Any suggestions would be helpful!! Thanks

weird, i have the following mods installed with not 1 single error.


AddOns:
Swatter, v3.1.9 (<%codename%>)
ACP, v3.0.3.0.10
AdvancedTradeSkillWindow, v
AdvancedTradeSkillWindowLevels, v2.0
AltInvite, v
ArenaCountDown, v1.0
ArkInventory, v3.02
Armory, v5.2.11
ArmoryGuildBank, v5.4
Atlas, v1.13.0
AtlasBattlegrounds, v1.13.0
AtlasDungeonLocs, v1.13.0
AtlasOutdoorRaids, v1.13.0
AtlasTransportation, v1.13.0
AtlasLoot, v5.02.06
AtlasQuest, v4.3.0
AucAdvanced, v5.1.3715 (SnaggleTooth)
AucFilterBasic, v5.1.3715 (SnaggleTooth)
AucFilterOutlier, v5.1.3715.2531
AucMatchUndercut, v5.1.3715.2531
AucStatClassic, v5.1.3715 (SnaggleTooth)
AucStatHistogram, v5.1.3715 (SnaggleTooth)
AucStatiLevel, v5.1.3715 (SnaggleTooth)
AucStatPurchased, v5.1.3715 (SnaggleTooth)
AucStatSales, v5.1.3715.2842
AucStatSimple, v5.1.3715 (SnaggleTooth)
AucStatStdDev, v5.1.3715 (SnaggleTooth)
AucStatWOWEcon, v5.1.3715.2530
AucUtilAHWindowControl, v5.1.3715.3311
AucUtilAppraiser, v5.1.3715.2530
AucUtilAskPrice, v5.1.3715.3175
AucUtilAutoMagic, v5.1.3715.3142
AucUtilCompactUI, v5.1.3715.2530
AucUtilEasyBuyout, v5.1.3715.3583
AucUtilItemSuggest, v5.1.3715.3108
AucUtilPriceLevel, v5.1.3715.2545
AucUtilScanButton, v5.1.3715.2530
AucUtilScanFinish, v5.1.3715.2530
AucUtilScanProgress, v5.1.3715.2530
AucUtilSearchUI, v5.1.3715.3483
AucUtilSimpleAuction, v5.1.3715.3708
AucUtilVendMarkup, v5.1.3715.2530
Auditor2, v3.2.1
AutoDing, v2.4.0
AutoProfitX, v2.04
Babylonian, v5.1.DEV.130
BeanCounter, v5.1.3715 (SnaggleTooth)
BigWigs, v2.0
Broker2FuBar, v1.0
BrokerLunarSphere, v1.0
BrokerQH, v30000-3
Cartographer, v2.0
CartographerBattlegrounds, v2.0
CartographerCoordinates, v2.0
CartographerFoglight, v2.0
CartographerGroupColors, v2.0
CartographerGuildPositions, v2.0
CartographerInstanceLoot, v2.0
CartographerInstanceMaps, v2.0
CartographerInstanceNotes, v2.0
CartographerLookNFeel, v2.0
CartographerNotes, v2.0
CartographerPOI, v2.0
CartographerProfessions, v2.0
CartographerQuestInfo, v
CartographerWaypoints, v2.0
CartographerZoneInfo, v2.0
ChatBar, v2.2
ChatSounds, v
Chronos, v
ClassLoot, vr58
CloseUp, v3.0.001
CombatCaller, v
Comix, v1.7 beta
Configator, v5.1.DEV.130
CowTip, v
CTMailMod, v3.0 (CTMod 3.0)
CustomChat, v2.9
DebugLib, v5.1.DEV.130
Enchantrix, v5.1.3715 (SnaggleTooth)
EnchantrixBarker, v5.1.3715 (SnaggleTooth)
EnhTooltip, v5.1.3715 (SnaggleTooth)
Examiner, v08.10.16
FishermansFriend, v
FlightMap, v
FuBar, v
FuBarArenaFu, v0.8
FuBarAuditorFu, v3.2.1
FuBarCalendarFu, v1.3.1
FuBarCombatTimeFu, v
FuBarEmoteFu2, v0.1.5
FuBarExperienceFu, v1.1 $Revision: 65606 $
FuBarFriendsFu, v2.4.2-99
FuBarGroupFu, v1
FuBarGuildFu, v2.4.2-113
FuBarMailExpiryFu, v1.4.2
FuBarMailFu, v2.0
FuBarPetInfoFu, v3.0.3 $Revision: 94 $
FuBarReloadUI, v2.0.0
FuBarSkillsPlusFu, v3.0.3
FuBarTopScoreFu, vv1.0.2
FuriousTask, v
FuTextures, v2.0
Gatherer, v3.1.9
IceHUD, vr326 (Revision: 326)
Incubator, v2.00
Informant, v5.1.3715 (SnaggleTooth)
ItemRack, v
LittleWigs, v3.0.0
LittleWigsTBC, v
LunarSphere, v1.000
LunarSphereExporter, v1.000
LyLock, v2.38
LyLockArmor, v2.35
LyLockBanish, v2.35
LyLockHealthstone, v2.34
LyLockSoulShard, v2.34
LyLockSoulstone, v2.36
LyLockSummon, v2.35
MultiAuction, v1.0
MultiAuctionAuctioneer, v1.0
NazScrooge, v1.65
Necrosis, v3.0 RC1
nUI, v4.09.00 (Beta)
nUIInfoPanelStats, v1.00.00
Omen, v3.0.4
oRA2, v2.0.$Revision: 628 $
PassLoot, v3.4
Proximo, v2.3
QuestHelper, v0.77
QuestProgressSound, v1.1
RecipeBook, v
Recount, v
Sea, v1.39
SharedMedia, v3.0
Stubby, v5.1.3715 (SnaggleTooth)
Talented, v1.9.4
tekKompare, v3.0.3.5
TMrecruit, v1.6.5
TradesBar, v2.12.3
VisualHeal, v
WebDKP, v2
WIM, v3.0.5
XLoot, v0.9
zzml, v2.3
(ck=eff)



are you running vista? if so then i recommend removing vista and trying xp lol j/k

vista sometime hides mods in weird places, a friend had the same problem and had to remove and completely reinstall the game to fix it.
 
01-02-09, 01:59 PM   #2209
fred
A Cobalt Mageweaver
Join Date: Mar 2006
Posts: 208
Haha! No Vista.But I did some more research....and this is what I found.with just nUI installed wit no other mods I noticed the very slight 'hitch'..almost un noticeable.The more mods I loaded back in the more noticeable it was.When I loaded all my modss back in it was nearly unplayable solo, no idea what a group would have been like.Loaded v4.06.00 (Beta) back in and it went away completely. I have/had no errors with nUI though.And as of today with testing no other errors either.

On another note. Is it me or does Swatter from Auctioneer pick up errors more that Bugsack? Swatter yesterday picked up an error with libbabbleclass error yesterday ,even after deleting the wtf a few times.Today I started fresh again with Bugsack and haven't seen the error. Seems strange to me
 
01-02-09, 02:39 PM   #2210
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Fred -- drop me an e-mail at [email protected] and I'll send you the copy I'm playing with right now... I want to see if it makes your problem go away. I'm starting to wonder if there's something about the profiling code that's causing issues on some systems.

Originally Posted by fred View Post
Haha! No Vista.But I did some more research....and this is what I found.with just nUI installed wit no other mods I noticed the very slight 'hitch'..almost un noticeable.The more mods I loaded back in the more noticeable it was.When I loaded all my modss back in it was nearly unplayable solo, no idea what a group would have been like.Loaded v4.06.00 (Beta) back in and it went away completely. I have/had no errors with nUI though.And as of today with testing no other errors either.

On another note. Is it me or does Swatter from Auctioneer pick up errors more that Bugsack? Swatter yesterday picked up an error with libbabbleclass error yesterday ,even after deleting the wtf a few times.Today I started fresh again with Bugsack and haven't seen the error. Seems strange to me
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
 
01-02-09, 03:01 PM   #2211
tintingurl
A Frostmaul Preserver
 
tintingurl's Avatar
Join Date: Jan 2007
Posts: 295
Originally Posted by spiel2001 View Post
You were grouped with *one* person and the FPS dropped to 12?

/sigh

The only thing I can suggest is the same thing I always seem to suggest in cases like this... try exiting WoW and renaming your World of Warcraft > WTF folder to World of Warcraft > WTF.saved and then log back in.

There has to be some kind of artifact thing going on here and I didn't see frame rates that low in a 40 man and I spent all night last night in a normal group and never saw frame rates below 40fps on a laptop. So something off is up.

A lot of "strange" behavior these last few days. I wish I had a clue why.
ok ty i will try that out.

and i wanted to thank you so much you answering things and questions anyone has for your UI, you keep up and running and i love it for that.(ive played with alot of UI's and they seem to shut down or stop updating them at a point, always seems to happen when i get really use to the UI too )
__________________
 
01-02-09, 03:56 PM   #2212
Sloth
An Aku'mai Servant
AddOn Author - Click to view addons
Join Date: Aug 2008
Posts: 32
Originally Posted by tintingurl View Post
(ive played with alot of UI's and they seem to shut down or stop updating them at a point, always seems to happen when i get really use to the UI too )
Do NOT touch nUI! It really isn't that good, you don't need it
 
01-02-09, 05:43 PM   #2213
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Exclamation nUI Beta v4.10.00 has just been released...

Yes... this is yet another unplanned update.

There have been quite a few reports from folks who are still experiencing screen tearing and intermittent lags that I can only assume there's still some core issue at hand. It seems the FPS thing came to a head at the same time I released the 4.07 -- which is when I introduced the profiling.

Now, in theory, when profiling is disabled it should have zero impact on the system since its just making calls to empty methods in that case. However, such does not appear to be the case and I can only assume its some odd artifact of how function calls are handled in LUA.

In any event, I have backed out all of the profiling code since it appears to be causing issues and we seem to have solved the original FPS leak issue. If I have to add it back at a later date, I'll do so in an alpha release, not a public release. Those of you with slower systems or heavily loaded systems who are continuing to have screen tearing and minilag issues in 4.09 should see that problem resolved in this update.

In addition, this update also fixes the broken hunter pet happiness indicator.

As always, please report any bugs you come across at the official support site at http://www.wowinterface.com/forums/s...ad.php?t=16845 if at all possible. Otherwise, bugs can be reported on any of the nUI comment boards or via direct e-mail to me at [email protected]

The current release is (or will be) available for download at any of the following locations...My continued thanks to everyone for their support!

How you can help support nUI's continued development: I am currently trying to recover from 14 months of unemployment and with over $20,000 in debt (unpaid mortgage payments, loans, etc.), every penny makes a serious difference. Your contribution of $5, $10, $20 or more to support the ongoing development of nUI would be greatly appreciated. Click here to make a donation now, please?!

Lastly, please vote for nUI and add it to your favorites list... it helps nUI get more exposure. Thanks for your support!


-------------------------------------------------------------------------------------------
Known Issues in nUI...
-------------------------------------------------------------------------------------------

-- WotLK issues still outstanding

* "Fire At Will!" quest does not work with nUI

* When using the mounts that can carry vendors, the dismount button is not being displayed
in nUI (note: until this gets fix, you can right-click the aura to dismount)

-- generic issues outstanding

* If you remove a fubar top panel, the nUI top panel redraws to the middle of the screen.
It is full width and takes up about 20% of the middle of the field of view vertically.

* Enabling the "Use UI Scale" option in the Bliz video configuration menu blows up
nUI's layout and scaling. For now... just uncheck this option until I can fix it.

-------------------------------------------------------------------------------------------
Known compatibility issues with third party mods...
-------------------------------------------------------------------------------------------

* Guild Event Manager is moving its minimap button back to the minimap out of the button
bag whenever the player clicks on it. A minute or so later, nUI's button bag logic
will see the button moved and return it to the button bag.

* Carbonite is having issues updating the directional arrow when the minimap and/or
battlefield minimap is hidden in the info panel

* Poison Pouch mod minimap button is missed by button bag

* Alpha Map minimap button is not scaling correctly in button bag

* nUI and Capping are not playing well... Capping's modification of the battlefield
minimap is interfering with nUI's info panel management of the map

* Titan Panel is causing an error when the bottom bar is enabled

* Titan panel mouseover tooltips are not compatible with nUI's fixed position
tooltip option

-------------------------------------------------------------------------------------------
Known Bliz / nUI compatibility issues...
-------------------------------------------------------------------------------------------

* Right clicking a unit frame and selecting "set focus" taints in combat == this is
a known bug since WoW 3.0.2 and is beyond nUI's control. Hopefully Bliz will address
it in the next patch (or two or three or twenty). You can target the desired focus
and then type '/focus' to aquire a focus frame until Bliz resolves this issue.

* Switching between windowed and non-windowed mode breaks nUI's textures and HUD -- this
is caused by a known Bliz bug in their video driver code and applies only to certain
graphics cards and video drivers. It is nearly random in terms of which mods it will
impact... anything from very complex to completely trivial mods are broken by this
bug but it is always mods that use custom textures. There is no fix. The only
workaround is to (a) avoid switching between windowed and non-windowed modes as much
as possible and use '/nui rl' to reload the user interface when it gets broken. It is
worth noting this bug affects Macs most often, but also impacts some PCs (such as
mine). This bug has been a round a very long time and no telling if or when it will
ever be fixed.

* If your mouse buttons 4 and 5 do not work for click-casting on unit frames, make
sure your mouse driver is sending mouse button clicks and not key presses. You can
do this by going to the key binding interface and trying to bind autorun to mouse
button 4. If the key binding does not say "Button 4" or "Mouse Button 4" then the
issue is your mouse driver or driver settings. Bliz does not support key-presses
as mouse clicks directly and mods like Clique cannot detect key presses in that way.

-------------------------------------------------------------------------------------------
To-Do List / Planned features
-------------------------------------------------------------------------------------------

* The 15, 20, 25 and 40 man raid panels are not in the pre-release... both because I am
not quite satisfied with them and, again, I'm trying to not have to fix everything at
once... make sure the core stuff is all working, then add the bells and whistles if
you understand.

* Add vehicle frame/mode integration to the dashboard

* Death Knights need a timer for their pet expiration... should also have a ghoul timer

* Add cooldown counters to the rune bar

* Add Threat Bar back

* Add sorting of raid unit frames by raid group and class

* Add font size options for Chat and Combat log frames

* Add totem timers

* Add audio cues for cooldowns, cc breaks, etc.

* Add DruidManaBar type functionality to unit frames

* Add 2v2, 3v3 and 5v5 unit frame panels for arena play

* Add Proximo functionality to unit frames for arena unit panels

* Add durability, wardrobe manager, ammo tracker and gold tracker to console buttons

* Add autobar style support for quest items, food/drink/pots, mounts, vanity pets

* Add option to set location precision to zero decimal places on coordinate display

* Add target marking tool a la LuckyCharms

* Add recommended zone functionality to the location box a la FuBar RecZone

* Add a swing timer

-------------------------------------------------------------------------------------------
Version 4.10.00 (Beta)
-------------------------------------------------------------------------------------------

* Fixed a bug in the pet happiness indicator that prevented it from updating while
your pet was being fed

* Removed the profiling method calls from all of the modules to improve overall
performance now that the FPS leak appears to be resolved. Given then number of
people who were having screen tearing issues with the simple memory accumulation
check, and the number of reports of continued screen tearing after that was removed
in the 4.09.00 release, it occurs to me that the overhead of the profiling is probably
as high or higher, so people on slower and/or more heavily loaded systems should see a
performance improvement as a result. People on fast systems likely will not see a change.

__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/
 
01-02-09, 06:24 PM   #2214
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Originally Posted by spiel2001 View Post
Yes... this is yet another unplanned update.
Great work Scott, thanks for all the updates, even tho I had hardly any problems :-)
 
01-02-09, 07:11 PM   #2215
Dethstalker
A Murloc Raider
Join Date: Dec 2008
Posts: 7
Scott,

You are a programming mad man! You are supposed to be enjoying the holidays!

I have not fully committed to switching to nUI but I have been following developments in nUI for some time now. I am currently using nUI on the PTRs and have been pretty happy with it.

Keep up the good work and take a breather here and there with the family during this holiday season!
 
01-02-09, 07:38 PM   #2216
spiritwulf
A Cobalt Mageweaver
 
spiritwulf's Avatar
AddOn Author - Click to view addons
Join Date: Oct 2006
Posts: 202
Originally Posted by spiel2001 View Post
Hard to say. But if there's one thing I'm supremely confident in with this mod is that left to its own devices (i.e. no outside interference) it will size fonts correctly. The only time you'll see font overlap (or should I guess) is really long mob names in unit frames or really long zone names in the location box and I just didn't sweat those because they are kind of the exception.
Nuking the font folder fixed that little overlap issue, thanks for catching that. God knows what mod did it but timers are readable now. Never realized the Blizz font was so lousy, maybe ill look for one that both fits and isnt so crummy looking lol. Chat was a lot easier to read with the modified font.

Originally Posted by spiel2001 View Post
Oh gawd... please DO NOT blame that thing on me! ~lol~
yeah i feel really ashamed about that, may have to send you more money again to molify my guilt



Originally Posted by spiel2001 View Post
Yeah... I don't know what that happens and I really wish I did so I could code a solution for it when it does. But it's not just nUI, a lot of mods seems to suddenly have issues with a weird WTF folder. Has to be a bug of some kind in WoW (there's none of those, right?)
Nah never any issues with Blizz. They dont change code or modify stuff without telling us and the lag issues are always network related and no fault of theirs.
__________________
Traveling through the night on padded feet
the ghost in the dark
to rend and kill
not for pleasure
but for survival
 
01-02-09, 08:05 PM   #2217
spiel2001
nUI's Author
 
spiel2001's Avatar
AddOn Author - Click to view addons
Join Date: Jun 2008
Posts: 7,724
Screen tearing / Minilags...

Okay... for the entire time people have been commenting on this I have never seen it. Tonight, out of the blue and without having logged or modified nUI, it started happening and exactly as others have described it... every five to ten seconds for just a brief moment.

The thing that immediately jumped out at me when this started happening was my hard drive was getting hit pretty hard at the same time and as I'm writing this it's continuing to get hit.

I could well be wrong on this, but I don't think it's nUI. I think this is a rolling modification to the realms. It could be related to the upcoming patch. It could be related to the end of Winterveil, or just an end of year thing... I dunno. But there is *nothing* in nUI which can or does write to the hard drive. So whatever is going on is happening behind the scenes in WoWland.

EDIT: Interesting to note... I left Northrend and went to Azeroth to complete some odds and ends I had been carrying in the log book and the stuttering went away. I went back to Northrend to continue questing and it returned.
__________________

What people don't get is that I am, ultimately, an artist at heart.
My brush has two colors, 1 and 0, and my canvas is made of silicon.



Official nUI Web Site: http://www.nUIaddon.com
Official nUI Support Forum: http://forums.nUIaddon.com
My day job: http://www.presidio.com/

Last edited by spiel2001 : 01-02-09 at 09:24 PM.
 
01-03-09, 01:58 AM   #2218
Kodewulf
Premium Member
 
Kodewulf's Avatar
Premium Member
AddOn Author - Click to view addons
Join Date: Dec 2005
Posts: 114
Two new nUI modules

Two new modules for nUI

nUI: Config [GUI] *BETA* *BETA* *BETA*
nUI: Config [ChatFrame]
__________________
I will never forget. I will never regret. I will live my life.
 
01-03-09, 04:21 AM   #2219
Petrah
A Pyroguard Emberseer
 
Petrah's Avatar
AddOn Author - Click to view addons
Join Date: Jan 2008
Posts: 2,988
Originally Posted by spiel2001 View Post
Okay... for the entire time people have been commenting on this I have never seen it. Tonight, out of the blue and without having logged or modified nUI, it started happening and exactly as others have described it... every five to ten seconds for just a brief moment.

The thing that immediately jumped out at me when this started happening was my hard drive was getting hit pretty hard at the same time and as I'm writing this it's continuing to get hit.

I could well be wrong on this, but I don't think it's nUI. I think this is a rolling modification to the realms. It could be related to the upcoming patch. It could be related to the end of Winterveil, or just an end of year thing... I dunno. But there is *nothing* in nUI which can or does write to the hard drive. So whatever is going on is happening behind the scenes in WoWland.

EDIT: Interesting to note... I left Northrend and went to Azeroth to complete some odds and ends I had been carrying in the log book and the stuttering went away. I went back to Northrend to continue questing and it returned.
Scott,

Wasn't sure if you had been following this sticky thread in tech support or not, and if not, it may be of interest to you.

http://forums.worldofwarcraft.com/th...68277969&sid=1

We have gotten reports where some systems may experience a performance drop roughly around every 15 seconds. Some deeper digging shows that the system SVCHOST.EXE and DPC to be spiking. We've seen similar issues in the past, where something like Windows Update would do it on a set timer. Example: http://support.microsoft.com/kb/916089
We do not think that's the case this time but it does sound similar.

To find out if this is your case, try checking this guide - http://www.howtogeek.com/howto/windo...is-it-running/
We recommend using Process Explorer (http://www.microsoft.com/technet/sys...sExplorer.mspx) as it's more user-friendly and can help you track things in Real-Time. Right-click on the Columns tab and go to Select Columns. Go to the Process Performance tab, then check the CPU History checkbox. Hit OK and that'll give you a graph for every single process running. Use this tool while the game is running to see what it's doing in general. Run the game in a windowed mode if possible so that you can alt+tab to Process Explorer easily and without delay.
If you see SVCHOST.EXE and DPC spike, try running Windows Update and update everything. If it did not help, we will need more information from you.
__________________
♪~ ( ) I My Sonos!
AddOn Authors: If your addon spams the chat box with "Addon v8.3.4.5.3 now loaded!", please add an option to disable it!

Last edited by Petrah : 01-03-09 at 04:24 AM.
 
01-03-09, 05:39 AM   #2220
Seer
A Molten Giant
Join Date: Dec 2007
Posts: 649
Thumbs up

Originally Posted by Kodewulf View Post
Two new modules for nUI

nUI: Config [GUI] *BETA* *BETA* *BETA*
nUI: Config [ChatFrame]
Thanks for the config tool, very handy.
 
 

WoWInterface » Featured Projects » nUI, MozzFullWorldMap and PartySpotter » Support » nUI: Technical Support » nUI -- A full feature standalone UI replacement

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off