Quantcast
ToolTip white out on first mouse over. - WoWInterface
Thread Tools Display Modes
06-04-10, 10:08 AM   #1
Grimsin
A Molten Giant
 
Grimsin's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2006
Posts: 990
ToolTip white out on first mouse over.

Wondering if someone might know why when i first log in the first thing i mouse over has a white out background at first? I am trying to hook my own background and boarder. Some methods the background whites out at different times or all the time.

this is the method im trying right now and it only whites out on first mouse over. id like it to never whiteout the perfectionist in me...

this method also allows for other tooltip addons to take over if they are installed or so it should anyhow... or at lest TipTac has no trouble over riding my code.

lua Code:
  1. -------------------
  2. -- GUI TT Anchor
  3. --------------------
  4. GUITTAnchor = CreateFrame("Frame", "GUITTAnchor", UIParent, "SecureHandlerStateTemplate");
  5. GUITTAnchor:SetPoint("LEFT", UIParent, "LEFT", 35, -130)
  6.  
  7.  
  8. GameTooltip:SetBackdrop{
  9.         bgFile = "Interface\\AddOns\\!GrimUI\\Art\\GrimMainbg",
  10.         edgeFile = "Interface\\AddOns\\!GrimUI\\Art\\HordeBoarder1", tile = false, edgeSize = 15,
  11.         insets = { left = 0, right = 0, top = 0, bottom = 0 }
  12.         }
  13.  
  14. hooksecurefunc("GameTooltip_OnLoad", function (self)
  15.  
  16.     GameTooltip:SetBackdrop{
  17.         bgFile = "Interface\\AddOns\\!GrimUI\\Art\\GrimMainbg",
  18.         edgeFile = "Interface\\AddOns\\!GrimUI\\Art\\HordeBoarder1", tile = false, edgeSize = 15,
  19.         insets = { left = 0, right = 0, top = 0, bottom = 0 }
  20.         }
  21.        
  22.        
  23. end)
  24.  
  25. hooksecurefunc("GameTooltip_SetDefaultAnchor", function (tooltip, parent)
  26.            
  27.             local tooltips = {GameTooltip, ItemRefTooltip, ShoppingTooltip1, ShoppingTooltip2, ShoppingTooltip3, WorldMapTooltip}
  28.             tooltip:SetOwner(parent,"ANCHOR_NONE")
  29.        
  30.             tooltip:SetPoint("LEFT",GUITTAnchor,"LEFT", 0, 0)
  31.             tooltip:SetPoint("BOTTOM",GUITTAnchor,"BOTTOM", 0, 0)
  32.            
  33.        
  34. end)
__________________
"Are we there yet?"

GrimUI
[SIGPIC][/SIGPIC]
  Reply With Quote
06-04-10, 02:09 PM   #2
v6o
An Onyxian Warder
AddOn Author - Click to view addons
Join Date: Mar 2009
Posts: 399
Have you tried setting the backdrop color after the first backdrop change?
__________________
I stopped playing back World of Warcraft in 2010 and I have no plans on returning.
This is a dead account and if you want to continue any of my addons or make a fork then feel free to do so.
This is your permission slip.

If you need to contact me, do so on Twitter @v6ooo

Best regards, v6.
  Reply With Quote
06-04-10, 04:59 PM   #3
Grimsin
A Molten Giant
 
Grimsin's Avatar
AddOn Author - Click to view addons
Join Date: Sep 2006
Posts: 990
hmm no, you mean after the first time my code sets it?

Thanks i added the setbackdropcolor to that matched the numbers up to bliz's onload code and bingo thanks!!!!
__________________
"Are we there yet?"

GrimUI
[SIGPIC][/SIGPIC]

Last edited by Grimsin : 06-04-10 at 08:38 PM.
  Reply With Quote

WoWInterface » Developer Discussions » Lua/XML Help » ToolTip white out on first mouse over.

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off